Skip to content
Laskyr

dompdf/dompdf security advisory

CVE-2026-55555: Dompdf: File existence oracle via font-face stylesheet declaration

CVE-2026-55555 is a low-severity security vulnerability in the PHP package dompdf/dompdf (CVSS 7.5), published 28 July 2026. It is fixed in 3.1.6; earlier versions are affected. It can be exploited without an account.

low 7.5 published 2026-07-28 · updated 2026-08-05

Fixed in dompdf/dompdf 3.1.6

This security issue affects dompdf/dompdf versions < 3.1.6. Upgrade to the fixed version for your release line (3.1.6). The newest release, 3.1.6, is not affected.

Affected versions
< 3.1.6
Fixed in
3.1.6
Newest release
3.1.6
Severity
Low · CVSS 7.5
Type
Security issue
CWE-203
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your dompdf/dompdf version affected?

Run composer show dompdf/dompdf in your project, then enter the version. We check it against this and every other known dompdf/dompdf advisory.

Who can exploit CVE-2026-55555

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of dompdf/dompdf. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-55555 in dompdf/dompdf

  1. Find the installed version: composer show dompdf/dompdf. If you never required it yourself, composer why dompdf/dompdf shows which package pulls it in.
  2. Update it: composer update dompdf/dompdf --with-all-dependencies. You need 3.1.6 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "dompdf/dompdf": "^3.1.6" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-55555.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-55555 advisory

Dompdf is an HTML to PDF converter for PHP. Versions 3.15 and prior are vulnerable to a File Existence Oracle attack through the manipulation of the CSS @font-face directive. By providing malicious HTML that references local files via the file:// protocol repeatedly, an attacker can trigger PHP memory exhaustion. Because Dompdf behaves differently depending on whether a referenced local file exists (an existing file is processed repeatedly until it triggers an "Allowed memory size exhausted" crash, whereas a missing file fails fast or is ignored and never hits the memory limit), an attacker can use this observable discrepancy as an oracle to enumerate sensitive files on the server regardless of CHROOT restrictions. Exploitation requires the attacker to supply unrestricted or unsanitized HTML in a request that permits large data, plus a configuration where Dompdf's memory limit is low enough to be exhausted (with  $_dompdf_show_warnings=true  making the overflow easier to reach). This issue has been fixed in version 3.16.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-55555. Advisory title: “Dompdf: File existence oracle via font-face stylesheet declaration”.

References

Other dompdf/dompdf advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit