Skip to content
Laskyr

guzzlehttp/guzzle security advisory

CVE-2026-55767: Dot-only cookie domains match all hosts in guzzlehttp/guzzle

CVE-2026-55767 is a medium-severity session fixation vulnerability in the PHP package guzzlehttp/guzzle (CVSS 5.8), published 23 June 2026. It is fixed in 7.12.1; earlier versions are affected. It can be exploited without an account.

medium 5.8 published 2026-06-23 · updated 2026-08-05

Fixed in guzzlehttp/guzzle 7.12.1

This session fixation issue affects guzzlehttp/guzzle versions < 7.12.1. Upgrade to the fixed version for your release line (7.12.1). The newest release, 8.3.1, is not affected.

Affected versions
< 7.12.1
Fixed in
7.12.1
Newest release
8.3.1
Severity
Medium · CVSS 5.8
Type
Session fixation
CWE-346, CWE-1286
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your guzzlehttp/guzzle version affected?

Run composer show guzzlehttp/guzzle in your project, then enter the version. We check it against this and every other known guzzlehttp/guzzle advisory.

Who can exploit CVE-2026-55767

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of guzzlehttp/guzzle. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-55767 in guzzlehttp/guzzle

  1. Find the installed version: composer show guzzlehttp/guzzle. If you never required it yourself, composer why guzzlehttp/guzzle shows which package pulls it in.
  2. Update it: composer update guzzlehttp/guzzle --with-all-dependencies. You need 7.12.1 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "guzzlehttp/guzzle": "^7.12.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-55767.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for session fixation issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-55767 advisory

Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, CookieJar incorrectly accepts cookies with a dot-only Domain attribute and whitespace-padded variants. SetCookie::matchesDomain() removes leading dots from the cookie domain, normalizing dot-only values to the empty string; SetCookie::validate() only rejected a strictly empty domain, so these cookies could be stored and the empty normalized domain was treated as matching any request host. An attacker-controlled origin that an application requests with a shared cookie jar can therefore set a cookie that Guzzle later sends to unrelated hosts using the same jar. This may allow cookie injection or session fixation against downstream services, depending on how those services interpret the injected cookie. This vulnerability is fixed in 7.12.1.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-55767. Advisory title: “Dot-only cookie domains match all hosts”.

References

Other guzzlehttp/guzzle advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit