Skip to content
Laskyr

guzzlehttp/guzzle security advisory

CVE-2026-67353: Guzzle: Unbounded response cookies risk denial of service

CVE-2026-67353 is a medium-severity denial of service vulnerability in the PHP package guzzlehttp/guzzle (CVSS 5.3), published 1 August 2026. It is fixed in 7.15.1; earlier versions are affected. It can be exploited without an account.

medium 5.3 published 2026-08-01 · updated 2026-10-08

Fixed in guzzlehttp/guzzle 7.15.1

This denial of service issue affects guzzlehttp/guzzle versions < 7.15.1. Upgrade to the fixed version for your release line (7.15.1). The newest release, 8.3.1, is not affected.

Affected versions
< 7.15.1
Fixed in
7.15.1
Newest release
8.3.1
Severity
Medium · CVSS 5.3
Type
Denial of service
CWE-770
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your guzzlehttp/guzzle version affected?

Run composer show guzzlehttp/guzzle in your project, then enter the version. We check it against this and every other known guzzlehttp/guzzle advisory.

Who can exploit CVE-2026-67353

CVSS vector (scored by VulnCheck): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Your app is only exposed if it uses the affected part of guzzlehttp/guzzle. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-67353 in guzzlehttp/guzzle

  1. Find the installed version: composer show guzzlehttp/guzzle. If you never required it yourself, composer why guzzlehttp/guzzle shows which package pulls it in.
  2. Update it: composer update guzzlehttp/guzzle --with-all-dependencies. You need 7.15.1 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "guzzlehttp/guzzle": "^7.15.1" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-67353.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for denial of service issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-67353 advisory

guzzlehttp/guzzle versions before 7.15.1 contain a denial of service vulnerability in the CookieJar that accepts unlimited Set-Cookie header fields with no size restrictions. Attackers can return many large cookies from a malicious server, causing Guzzle to store excessive data in memory and generate oversized Cookie headers that fail in handlers or destination servers.

Description from the CVE record, published by VulnCheck (the CVE Numbering Authority), via the NVD entry for CVE-2026-67353. Advisory title: “Guzzle: Unbounded response cookies risk denial of service”.

References

Other guzzlehttp/guzzle advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit