guzzlehttp/guzzle security advisory
CVE-2026-55568: Silent HTTPS proxy downgrade to cleartext in guzzlehttp/guzzle
CVE-2026-55568 is a medium-severity security vulnerability in the PHP package guzzlehttp/guzzle (CVSS 5.9), published 23 June 2026. It is fixed in 7.12.1; earlier versions are affected. It can be exploited without an account.
medium 5.9 published 2026-06-23 · updated 2026-06-26
- Affected versions
- < 7.12.1
- Fixed in
- 7.12.1
- Newest release
- 8.3.1
- Severity
- Medium · CVSS 5.9
- Type
- Security issue
CWE-311, CWE-319, CWE-636 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your guzzlehttp/guzzle version affected?
Who can exploit CVE-2026-55568
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
How to fix CVE-2026-55568 in guzzlehttp/guzzle
- Find the installed version:
composer show guzzlehttp/guzzle. If you never required it yourself,composer why guzzlehttp/guzzleshows which package pulls it in. - Update it:
composer update guzzlehttp/guzzle --with-all-dependencies. You need 7.12.1 or newer. - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"guzzlehttp/guzzle": "^7.12.1"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-55568. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-55568 advisory
Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.
References
- GitHub security advisory GHSA-wpwq-4j6v-78m3 github.com
Other guzzlehttp/guzzle advisories
- high CVE-2026-69246: Guzzle: Noncanonical host can bypass host-based checks 2026-08-03
- medium CVE-2026-69245: Guzzle: Noncanonical cookie domain keeps subdomain scope 2026-08-03
- medium CVE-2026-67354: Guzzle: URI fragments disclosed in redirect Referer headers 2026-07-20
- medium CVE-2026-67355: Guzzle: Host-only cookie scope is not preserved 2026-07-20
- medium CVE-2026-67353: Guzzle: Unbounded response cookies risk denial of service 2026-07-20
- medium CVE-2026-59883: Guzzle: Cookie Disclosure and Injection via IP-Address Domains 2026-07-20
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.