cakephp/cakephp security advisory
CVE-2026-48820: CakePHP: View::element() is missing a path containment check
CVE-2026-48820 is a medium-severity path traversal vulnerability in the PHP package cakephp/cakephp (CVSS 6.3), published 17 June 2026. It is fixed in 4.5.11, 4.6.4, 5.1.7, 5.2.13 and 5.3.6, one per release line; earlier versions on each line are affected. It can be exploited without an account.
medium 6.3 published 2026-06-17 · updated 2026-06-23
- Affected versions
- < 4.5.11
>= 4.6.0, < 4.6.4
>= 5.0.0, < 5.1.7
>= 5.2.0, < 5.2.13
>= 5.3.0, < 5.3.6 - Fixed in
- 4.5.11, 4.6.4, 5.1.7, 5.2.13, 5.3.6
- Newest release
- 5.4.4
- Severity
- Medium · CVSS 6.3
- Type
- Path traversal / file read
CWE-22, CWE-98 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Is your cakephp/cakephp version affected?
Who can exploit CVE-2026-48820
- Access: No account. Anyone who can send a request to an app that uses the affected code.
- Conditions: It only works under specific conditions the attacker does not fully control (CVSS rates the attack as high complexity).
CVSS vector (scored by GitHub): CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
How to fix CVE-2026-48820 in cakephp/cakephp
- Find the installed version:
composer show cakephp/cakephp. If you never required it yourself,composer why cakephp/cakephpshows which package pulls it in. - Update it:
composer update cakephp/cakephp --with-all-dependencies. You need the fixed version for your release line (4.5.11, 4.6.4, 5.1.7, 5.2.13 and 5.3.6). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"cakephp/cakephp": "^5.3.6"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2026-48820. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- Validate file names against an allow-list and reject paths containing ../ or absolute paths.
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2026-48820 advisory
CakePHP is a rapid development framework for PHP. In versions 4.5.11 and earlier, 4.6.0 through 4.6.3, 5.0.0 through 5.1.6, 5.2.0 through 5.2.12, and 5.3.0 through 5.3.5, View::_getElementFileName() does not check that the resolved element path is within the application/plugin view template paths. When element names are created with specifically crafted user-supplied data this weakness can be leveraged to include other PHP files on the server. Patched releases are available in 5.3.6, 5.2.13, 5.1.7, 4.6.4, and 4.5.11.
References
- GitHub advisory GHSA-wpvj-hjcr-h3p2 github.com
Other cakephp/cakephp advisories
- critical CVE-2026-79752: CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection 2026-09-17
- critical CVE-2026-77635: CakePHP: FunctionsBuilder::jsonValue() vulerable to SQL injection with PostgresDriver 2026-09-08
- high CVE-2026-77634: CakePHP: SmtpTransport vulnerable to CRLF header injection 2026-09-08
- medium CVE-2026-23643: CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting 2026-01-16
- critical CVE-2023-22727: CakePHP Database\\Query::offset() and limit() methods are vulnerable to SQL injection 2023-01-20
- high CVE-2020-35239: CakePHP allows method override parameters to bypass CSRF checks 2022-05-24
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.