Skip to content
Laskyr

cakephp/cakephp security advisory

CVE-2026-23643: CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

CVE-2026-23643 is a medium-severity XSS vulnerability in the PHP package cakephp/cakephp (CVSS 5.4), published 16 January 2026. It is fixed in 5.2.12; earlier versions are affected. It can be exploited without an account.

medium 5.4 published 2026-01-16 · updated 2026-06-17

Fixed in cakephp/cakephp 5.2.12

This XSS issue affects cakephp/cakephp in 2 release lines: =5.3.0; >=5.2.10,<5.2.12. Upgrade to the fixed version for your release line (5.2.12). The newest release, 5.4.4, is not affected.

Affected versions
=5.3.0
>=5.2.10,<5.2.12
Fixed in
5.2.12
Newest release
5.4.4
Severity
Medium · CVSS 5.4
Type
Cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your cakephp/cakephp version affected?

Run composer show cakephp/cakephp in your project, then enter the version. We check it against this and every other known cakephp/cakephp advisory.

Who can exploit CVE-2026-23643

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of cakephp/cakephp. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-23643 in cakephp/cakephp

  1. Find the installed version: composer show cakephp/cakephp. If you never required it yourself, composer why cakephp/cakephp shows which package pulls it in.
  2. Update it: composer update cakephp/cakephp --with-all-dependencies. You need 5.2.12 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "cakephp/cakephp": "^5.2.12" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-23643.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-23643 advisory

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-23643. Advisory title: “CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting”.

References

Other cakephp/cakephp advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit