Skip to content
Laskyr

symfony/http-client security advisory

CVE-2026-48736: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient in symfony/http-client

CVE-2026-48736 is a medium-severity SSRF vulnerability in the PHP package symfony/http-client (CVSS 8.6), published 14 July 2026. It is fixed in 5.4.53; earlier versions are affected. It can be exploited without an account.

medium 8.6 published 2026-07-14 · updated 2026-07-16

Fixed in symfony/http-client 5.4.53

This SSRF issue affects symfony/http-client versions >= 5.4.0, < 5.4.53. Upgrade to the fixed version for your release line (5.4.53). The newest release, 8.1.10, is not affected.

Affected versions
>= 5.4.0, < 5.4.53
Fixed in
5.4.53
Newest release
8.1.10
Severity
Medium · CVSS 8.6
Type
Server-side request forgery (SSRF)
CWE-184, CWE-918
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Also affects

The same advisory covers other packages in our list. Fix whichever one your project installs.

Is your symfony/http-client version affected?

Run composer show symfony/http-client in your project, then enter the version. We check it against this and every other known symfony/http-client advisory.

Who can exploit CVE-2026-48736

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Your app is only exposed if it uses the affected part of symfony/http-client. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-48736 in symfony/http-client

  1. Find the installed version: composer show symfony/http-client. If you never required it yourself, composer why symfony/http-client shows which package pulls it in.
  2. Update it: composer update symfony/http-client --with-all-dependencies. You need 5.4.53 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/http-client": "^5.4.53" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-48736.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for SSRF issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-48736 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 5.4.0 to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, NoPrivateNetworkHttpClient and IpUtils::PRIVATE_SUBNETS omitted IPv6 transition prefixes such as 6to4, NAT64, Teredo, and IPv4-compatible IPv6, allowing attacker-supplied URLs to represent private IPv4 targets in forms that IpUtils::isPrivateIp() did not block. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-48736. Advisory title: “CVE-2026-48736: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient”.

References

Other symfony/http-client advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit