PHP package security
Is symfony/http-client vulnerable?
2 known security advisories for symfony/http-client. The latest was reported on 2026-05-26 and is fixed in 5.4.53. The newest release, 8.1.10, is not affected by any of them.
1 medium 1 low
- Known advisories
- 2
- Newest release
- 8.1.10
- Released
- 2026-10-26
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for symfony/http-client
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2026-05-26 | CVE-2026-48736: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient CVE-2026-48736 · GitHub, FriendsOfPHP/security-advisories | medium | >=5.4.0,<5.4.53 | 5.4.53 |
| 2024-11-13 | CVE-2024-50342: Internal address and port enumeration allowed by NoPrivateNetworkHttpClient CVE-2024-50342 · GitHub, FriendsOfPHP/security-advisories | low | >=4.3.0,<4.4.0 | >=4.4.0,<5.0.0 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.47 | >=6.0.0,<6.1.0 | >=6.1.0,<6.2.0 | >=6.2.0,<6.3.0 | >=6.3.0,<6.4.0 | >=6.4.0,<6.4.15 | >=7.0.0,<7.1.0 | >=7.1.0,<7.1.8 | 4.4.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.47, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.15, 7.1.0, 7.1.8 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about symfony/http-client
Does symfony/http-client have known vulnerabilities?
Yes. Packagist lists 2 security advisories for symfony/http-client (1 medium, 1 low severity). The most recent, reported 2026-05-26, is "CVE-2026-48736: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient". The newest release, 8.1.10, is outside every affected range.
Which version of symfony/http-client should I run?
The newest stable release is 8.1.10 (published 2026-10-26). The most recent advisory is fixed in 5.4.53, so stay on or above the fixed version for your major version. Run composer update symfony/http-client, then composer audit to confirm nothing else is flagged.
How do I check if my symfony/http-client version is affected?
Run composer show symfony/http-client in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.