PHP package security
Is symfony/http-kernel vulnerable?
8 known security advisories for symfony/http-kernel. The latest was reported on 2026-05-20 and is fixed in 7.4.12 and 8.0.12. The newest release, 8.1.10, is not affected by any of them.
4 high 4 medium
- Known advisories
- 8
- Newest release
- 8.1.10
- Released
- 2026-10-28
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for symfony/http-kernel
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2026-05-20 | CVE-2026-45075: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid] CVE-2026-45075 · GitHub, FriendsOfPHP/security-advisories | high | >=7.4.0,<7.4.12 | >=8.0.0,<8.0.12 | 7.4.12, 8.0.12 |
| 2023-02-01 | CVE-2022-24894: Prevent storing cookie headers in HttpCache CVE-2022-24894 · GitHub, FriendsOfPHP/security-advisories | medium | >=2.0.0,<2.1.0 | >=2.1.0,<2.2.0 | >=2.2.0,<2.3.0 | >=2.3.0,<2.4.0 | >=2.4.0,<2.5.0 | >=2.5.0,<2.6.0 | >=2.6.0,<2.7.0 | >=2.7.0,<2.8.0 | >=2.8.0,<3.0.0 | >=3.0.0,<3.1.0 | >=3.1.0,<3.2.0 | >=3.2.0,<3.3.0 | >=3.3.0,<3.4.0 | >=3.4.0,<4.0.0 | >=4.0.0,<4.1.0 | >=4.1.0,<4.2.0 | >=4.2.0,<4.3.0 | >=4.3.0,<4.4.0 | >=4.4.0,<4.4.50 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.20 | >=6.0.0,<6.0.20 | >=6.1.0,<6.1.12 | >=6.2.0,<6.2.6 | 2.1.0, 2.2.0, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0, 2.8.0, 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.50, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.20, 6.0.20, 6.1.12, 6.2.6 |
| 2021-10-09 | CVE-2021-41267: Webcache Poisoning via X-Forwarded-Prefix and sub-request CVE-2021-41267 · GitHub, FriendsOfPHP/security-advisories | medium | >=5.2.0,<5.3.0 | >=5.3.0,<5.3.12 | 5.3.0, 5.3.12 |
| 2020-09-02 | CVE-2020-15094: Prevent RCE when calling untrusted remote with CachingHttpClient CVE-2020-15094 · GitHub, FriendsOfPHP/security-advisories | high | >=4.3.0,<4.4.0 | >=4.4.0,<4.4.13 | >=5.0.0,<5.1.0 | >=5.1.0,<5.1.5 | 4.4.0, 4.4.13, 5.1.0, 5.1.5 |
| 2019-11-13 | CVE-2019-18887: Use constant time comparison in UriSigner CVE-2019-18887 · GitHub, FriendsOfPHP/security-advisories | high | >=2.2.0,<2.3.0 | >=2.3.0,<2.4.0 | >=2.4.0,<2.5.0 | >=2.5.0,<2.6.0 | >=2.6.0,<2.7.0 | >=2.7.0,<2.8.0 | >=2.8.0,<2.8.52 | >=3.0.0,<3.1.0 | >=3.1.0,<3.2.0 | >=3.2.0,<3.3.0 | >=3.3.0,<3.4.0 | >=3.4.0,<3.4.35 | >=4.0.0,<4.1.0 | >=4.1.0,<4.2.0 | >=4.2.0,<4.2.12 | >=4.3.0,<4.3.8 | 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0, 2.8.0, 2.8.52, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.4.35, 4.1.0, 4.2.0, 4.2.12, 4.3.8 |
| 2015-05-26 | CVE-2015-4050: ESI unauthorized access CVE-2015-4050 · GitHub, FriendsOfPHP/security-advisories | medium | >=2.3.19,<2.3.29 | >=2.4.9,<2.5.0 | >=2.5.4,<2.5.12 | >=2.6.0,<2.6.8 | 2.3.29, 2.5.0, 2.5.12, 2.6.8 |
| 2015-04-01 | Esi Code Injection CVE-2015-2308 · GitHub, FriendsOfPHP/security-advisories | medium | >=2.0.0,<2.1.0 | >=2.1.0,<2.2.0 | >=2.2.0,<2.3.0 | >=2.3.0,<2.3.27 | >=2.4.0,<2.5.0 | >=2.5.0,<2.5.11 | >=2.6.0,<2.6.6 | 2.1.0, 2.2.0, 2.3.0, 2.3.27, 2.5.0, 2.5.11, 2.6.6 |
| 2014-09-03 | Direct access of ESI URLs behind a trusted proxy CVE-2014-5245 · GitHub, FriendsOfPHP/security-advisories | high | >=2.0.0,<2.1.0 | >=2.1.0,<2.2.0 | >=2.2.0,<2.3.0 | >=2.3.0,<2.3.19 | >=2.4.0,<2.4.9 | >=2.5.0,<2.5.4 | 2.1.0, 2.2.0, 2.3.0, 2.3.19, 2.4.9, 2.5.4 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about symfony/http-kernel
Does symfony/http-kernel have known vulnerabilities?
Yes. Packagist lists 8 security advisories for symfony/http-kernel (4 high, 4 medium severity). The most recent, reported 2026-05-20, is "CVE-2026-45075: HEAD Request Bypasses methods: ['GET'] Filter in #[IsGranted] / #[IsSignatureValid] / #[IsCsrfTokenValid]". The newest release, 8.1.10, is outside every affected range.
Which version of symfony/http-kernel should I run?
The newest stable release is 8.1.10 (published 2026-10-28). The most recent advisory is fixed in 7.4.12 and 8.0.12, so stay on or above the fixed version for your major version. Run composer update symfony/http-kernel, then composer audit to confirm nothing else is flagged.
How do I check if my symfony/http-kernel version is affected?
Run composer show symfony/http-kernel in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.