Skip to content
Laskyr

symfony/twig-bridge security advisory

CVE-2026-45072: Stored XSS in WebProfiler CodeExtension::fileExcerpt(): Unescaped Non-PHP File Rendering in symfony/twig-bridge

CVE-2026-45072 is a low-severity stored XSS vulnerability in the PHP package symfony/twig-bridge (CVSS 5.4), published 14 July 2026. It is fixed in 6.4.40; earlier versions are affected. Exploiting it needs a low-privilege user account.

low 5.4 published 2026-07-14 · updated 2026-07-16

Fixed in symfony/twig-bridge 6.4.40

This stored XSS issue affects symfony/twig-bridge versions >= 6.4.24, < 6.4.40. Upgrade to the fixed version for your release line (6.4.40). The newest release, 8.1.10, is not affected.

Affected versions
>= 6.4.24, < 6.4.40
Fixed in
6.4.40
Newest release
8.1.10
Severity
Low · CVSS 5.4
Type
Stored cross-site scripting (XSS)
CWE-79
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Also affects

The same advisory covers another package in our list. Fix whichever one your project installs.

Is your symfony/twig-bridge version affected?

Run composer show symfony/twig-bridge in your project, then enter the version. We check it against this and every other known symfony/twig-bridge advisory.

Who can exploit CVE-2026-45072

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Your app is only exposed if it uses the affected part of symfony/twig-bridge. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45072 in symfony/twig-bridge

  1. Find the installed version: composer show symfony/twig-bridge. If you never required it yourself, composer why symfony/twig-bridge shows which package pulls it in.
  2. Update it: composer update symfony/twig-bridge --with-all-dependencies. You need 6.4.40 or newer.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/twig-bridge": "^6.4.40" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45072.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for stored XSS issues while the upgrade waits. None of it replaces the fix.

The CVE-2026-45072 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. From 6.4.24 until 6.4.40, 7.4.12, and 8.0.12, the development profiler file_excerpt Twig filter escapes PHP files through highlight_string() but interpolates lines from non-PHP files directly into <code> elements, allowing stored XSS against a developer who opens an attacker-written file such as var/log/dev.log in the profiler. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45072. Advisory title: “CVE-2026-45072: Stored XSS in WebProfiler CodeExtension::fileExcerpt(): Unescaped Non-PHP File Rendering”.

References

Other symfony/twig-bridge advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit