Skip to content
Laskyr

PHP package security

Is symfony/twig-bridge vulnerable?

2 known security advisories for symfony/twig-bridge. The latest was reported on 2026-05-20 and is fixed in 6.4.40. The newest release, 8.1.10, is not affected by any of them.

1 medium 1 low

Known advisories
2
Newest release
8.1.10
Released
2026-10-15
Affecting newest release
0
Last synced
2026-11-03

Provides integration for Twig with various Symfony components · packagist.org/packages/symfony/twig-bridge

Check your version

Run composer show symfony/twig-bridge in your project to see the installed version, then enter it here.

Security advisories for symfony/twig-bridge

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2026-05-20 CVE-2026-45072: Stored XSS in WebProfiler CodeExtension::fileExcerpt(): Unescaped Non-PHP File Rendering CVE-2026-45072 · GitHub, FriendsOfPHP/security-advisories low >=6.4.24,<6.4.40 6.4.40
2023-11-10 CVE-2023-46734: Potential XSS vulnerabilities in CodeExtension filters CVE-2023-46734 · GitHub, FriendsOfPHP/security-advisories medium >=2.0.0,<2.1.0 | >=2.1.0,<2.2.0 | >=2.2.0,<2.3.0 | >=2.3.0,<2.4.0 | >=2.4.0,<2.5.0 | >=2.5.0,<2.6.0 | >=2.6.0,<2.7.0 | >=2.7.0,<2.8.0 | >=2.8.0,<3.0.0 | >=3.0.0,<3.1.0 | >=3.1.0,<3.2.0 | >=3.2.0,<3.3.0 | >=3.3.0,<3.4.0 | >=3.4.0,<4.0.0 | >=4.0.0,<4.1.0 | >=4.1.0,<4.2.0 | >=4.2.0,<4.3.0 | >=4.3.0,<4.4.0 | >=4.4.0,<4.4.51 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.31 | >=6.0.0,<6.1.0 | >=6.1.0,<6.2.0 | >=6.2.0,<6.3.0 | >=6.3.0,<6.3.8 2.1.0, 2.2.0, 2.3.0, 2.4.0, 2.5.0, 2.6.0, 2.7.0, 2.8.0, 3.0.0, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.4.0, 4.4.51, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.31, 6.1.0, 6.2.0, 6.3.0, 6.3.8

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about symfony/twig-bridge

Does symfony/twig-bridge have known vulnerabilities?

Yes. Packagist lists 2 security advisories for symfony/twig-bridge (1 medium, 1 low severity). The most recent, reported 2026-05-20, is "CVE-2026-45072: Stored XSS in WebProfiler CodeExtension::fileExcerpt(): Unescaped Non-PHP File Rendering". The newest release, 8.1.10, is outside every affected range.

Which version of symfony/twig-bridge should I run?

The newest stable release is 8.1.10 (published 2026-10-15). The most recent advisory is fixed in 6.4.40, so stay on or above the fixed version for your major version. Run composer update symfony/twig-bridge, then composer audit to confirm nothing else is flagged.

How do I check if my symfony/twig-bridge version is affected?

Run composer show symfony/twig-bridge in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit