Skip to content
Laskyr

symfony/mailer security advisory

CVE-2026-45068: Argument Injection in SendmailTransport via Dash-Prefixed Recipient Address in symfony/mailer

CVE-2026-45068 is a medium-severity security vulnerability in the PHP package symfony/mailer (CVSS 7.5), published 14 July 2026. It is fixed in 5.4.52, 6.4.40, 7.4.12 and 8.0.12, one per release line; earlier versions on each line are affected. It can be exploited without an account.

medium 7.5 published 2026-07-14 · updated 2026-07-15

Fixed in symfony/mailer 5.4.52, 6.4.40, 7.4.12 and 8.0.12

This security issue affects symfony/mailer in 4 release lines: >= 2.0.0, < 5.4.52; >= 6.0.0, < 6.4.40; >= 7.0.0, < 7.4.12; >= 8.0.0, < 8.0.12. Upgrade to the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12). The newest release, 8.1.10, is not affected.

Affected versions
>= 2.0.0, < 5.4.52
>= 6.0.0, < 6.4.40
>= 7.0.0, < 7.4.12
>= 8.0.0, < 8.0.12
Fixed in
5.4.52, 6.4.40, 7.4.12, 8.0.12
Newest release
8.1.10
Severity
Medium · CVSS 7.5
Type
Security issue
CWE-88
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Also affects

The same advisory covers another package in our list. Fix whichever one your project installs.

Is your symfony/mailer version affected?

Run composer show symfony/mailer in your project, then enter the version. We check it against this and every other known symfony/mailer advisory.

Who can exploit CVE-2026-45068

CVSS vector (scored by NVD): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Your app is only exposed if it uses the affected part of symfony/mailer. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-45068 in symfony/mailer

  1. Find the installed version: composer show symfony/mailer. If you never required it yourself, composer why symfony/mailer shows which package pulls it in.
  2. Update it: composer update symfony/mailer --with-all-dependencies. You need the fixed version for your release line (5.4.52, 6.4.40, 7.4.12 and 8.0.12).
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "symfony/mailer": "^8.0.12" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-45068.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-45068 advisory

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, SendmailTransport in -t mode appended recipient addresses to the sendmail command line without a -- end-of-options separator, allowing an address beginning with - to be interpreted as a sendmail command-line option instead of an address. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-45068. Advisory title: “CVE-2026-45068: Argument Injection in SendmailTransport via Dash-Prefixed Recipient Address”.

References

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit