PHP package security
Is symfony/mailer vulnerable?
1 known security advisory for symfony/mailer. The latest was reported on 2026-05-20 and is fixed in 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.52, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.40, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.12 and 8.0.12. The newest release, 8.1.10, is not affected by any of them.
1 medium
- Known advisories
- 1
- Newest release
- 8.1.10
- Released
- 2026-10-23
- Affecting newest release
- 0
- Last synced
- 2026-11-03
Check your version
Security advisories for symfony/mailer
| Reported | Advisory | Severity | Affected | Fixed in |
|---|---|---|---|---|
| 2026-05-20 | CVE-2026-45068: Argument Injection in SendmailTransport via Dash-Prefixed Recipient Address CVE-2026-45068 · GitHub, FriendsOfPHP/security-advisories | medium | >=2.0.0,<3.0.0 | >=3.0.0,<4.0.0 | >=4.0.0,<5.0.0 | >=5.0.0,<5.1.0 | >=5.1.0,<5.2.0 | >=5.2.0,<5.3.0 | >=5.3.0,<5.4.0 | >=5.4.0,<5.4.52 | >=6.0.0,<6.1.0 | >=6.1.0,<6.2.0 | >=6.2.0,<6.3.0 | >=6.3.0,<6.4.0 | >=6.4.0,<6.4.40 | >=7.0.0,<7.1.0 | >=7.1.0,<7.2.0 | >=7.2.0,<7.3.0 | >=7.3.0,<7.4.0 | >=7.4.0,<7.4.12 | >=8.0.0,<8.0.12 | 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.52, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.40, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.12, 8.0.12 |
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixCheck your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.
Check composer.lockQuestions about symfony/mailer
Does symfony/mailer have known vulnerabilities?
Yes. Packagist lists 1 security advisory for symfony/mailer (1 medium severity). The most recent, reported 2026-05-20, is "CVE-2026-45068: Argument Injection in SendmailTransport via Dash-Prefixed Recipient Address". The newest release, 8.1.10, is outside every affected range.
Which version of symfony/mailer should I run?
The newest stable release is 8.1.10 (published 2026-10-23). The most recent advisory is fixed in 3.0.0, 4.0.0, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.4.0, 5.4.52, 6.1.0, 6.2.0, 6.3.0, 6.4.0, 6.4.40, 7.1.0, 7.2.0, 7.3.0, 7.4.0, 7.4.12 and 8.0.12, so stay on or above the fixed version for your major version. Run composer update symfony/mailer, then composer audit to confirm nothing else is flagged.
How do I check if my symfony/mailer version is affected?
Run composer show symfony/mailer in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.