Skip to content
Laskyr

CVE-2026-39778: Ansar Import cross-site scripting (XSS) vulnerability

high 7.1 published 2026-10-06

The record does not say which version fixes it

Ansar Import 2.1.2 and older is affected by this XSS issue. The latest release (2.1.3) is outside the affected range.

Affected versions
2.1.2 and older
Fixed in
unknown
Latest version
2.1.3
Severity
High · CVSS 7.1
Active installs
10,000+
Type
Cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

What to do now

  1. Update Ansar Import to the latest version (2.1.3). The record does not name a fixed version, so also read the advisory below.
  2. If you cannot update right away, deactivate it until you can.
  3. Not sure which version you run? Check your version against every known Ansar Import issue. With WP-CLI: wp plugin get ansar-import --field=version.
  4. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Unauthenticated Cross Site Scripting (XSS) in Ansar Import – One Click Starter Sites – for Elementor & Themes <= 2.1.2 versions.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-39778.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit