Skip to content
Laskyr

CVE-2026-118185: Security Optimizer authentication bypass vulnerability

high 7.5 published 2026-10-31 · updated 2026-11-02

Fixed in Security Optimizer 1.6.9

Security Optimizer older than 1.6.9 is affected by this authentication bypass issue. Sites on 1.6.9 or newer are not affected; the latest release is 1.6.9.

Affected versions
older than 1.6.9
Fixed in
1.6.9
Latest version
1.6.9
Severity
High · CVSS 7.5
Active installs
1+ million
Type
Authentication bypass

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update Security Optimizer to 1.6.9 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Security Optimizer issue. With WP-CLI: wp plugin get sg-security --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Security Optimizer WordPress plugin before 1.6.9 does not limit the number of two-factor authentication codes that can be submitted for a pending login, allowing an attacker who already knows a user's password to brute force the second factor and take over the account.

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-118185.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit