Plugins · sg-security · data as of 2026-11-01
Is Security Optimizer safe? Known vulnerabilities and latest version
- Latest version
- 1.6.9
- Last updated
- 2026-10-14
- Active installs
- 1+ million
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Secure your WordPress site from brute-force attacks, threats, malware, and bots. Free to use and easy to set up. — by SiteGround
What to do
- Update to the latest version (1.6.9). Anything older than 1.6.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get sg-security --field=version shows what you run; wp plugin update sg-security updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
not scored yet CVE-2026-118185 · published 2026-10-31
Security issue in Security Optimizer (older than 1.6.9)
- Affected
- older than 1.6.9
- Fixed in
- 1.6.9
- Range from
- CVE record (the advisory publisher)
Details from the advisory
The Security Optimizer WordPress plugin before 1.6.9 does not limit the number of two-factor authentication codes that can be submitted for a pending login, allowing an attacker who already knows a user's password to brute force the second factor and take over the account.
high 8.1 CVE-2026-82228 · published 2026-08-31
Security issue in Security Optimizer (1.6.6 and older)
- Affected
- 1.6.6 and older
- Fixed in
- 1.6.7
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Bypass Vulnerability in SiteGround Security <= 1.6.6 versions.
medium 5.3 CVE-2026-13342 · published 2026-08-06
Security issue in Security Optimizer (1.5.8 up to (not including) 1.6.5)
- Affected
- 1.5.8 up to (not including) 1.6.5
- Fixed in
- 1.6.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Security Optimizer WordPress plugin from 1.5.8 to 1.6.4 does not correctly validate requests to its optional IP-based login restriction feature, allowing the restriction to be bypassed so that unauthenticated requests from non-allowlisted IP addresses can reach and use the login form, defeating the access control the administrator configured.
medium 5.3 CVE-2025-66121 · published 2025-12-16
Missing authorization check in Security Optimizer (1.5.8 and older)
- Affected
- 1.5.8 and older
- Fixed in
- 1.5.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in SiteGround SiteGround Security sg-security allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SiteGround Security: from n/a through <= 1.5.8.
medium 5.4 CVE-2024-38774 · published 2024-11-01
Missing authorization check in Security Optimizer (1.5.0 and older)
- Affected
- 1.5.0 and older
- Fixed in
- 1.5.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in SiteGround SiteGround Security allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects SiteGround Security: from n/a through 1.5.0.
critical 9.8 CVE-2022-0992 · published 2022-04-19
Authentication bypass in Security Optimizer (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The SiteGround Security plugin for WordPress is vulnerable to authentication bypass that allows unauthenticated users to log in as administrative users due to missing identity verification on initial 2FA set-up that allows unauthenticated and unauthorized users to configure 2FA for pending accounts. Upon successful configuration, the attacker is logged in as that user without access to a username/password pair which is the expected first form of authentication. This affects versions up to, and including, 1.2.5.
NVD CVE-2022-0992Wordfence advisoryCode change (fix)Wordfence advisory
critical 9.8 CVE-2022-0993 · published 2022-04-19
Authentication bypass in Security Optimizer (1.2.5 and older)
- Affected
- 1.2.5 and older
- Fixed in
- 1.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The SiteGround Security plugin for WordPress is vulnerable to authentication bypass that allows unauthenticated users to log in as administrative users due to missing identity verification on the 2FA back-up code implementation that logs users in upon success. This affects versions up to, and including, 1.2.5.
NVD CVE-2022-0993Wordfence advisoryCode change (fix)Wordfence advisory
Recent activity
- 2026-10-14 — latest release on wordpress.org (1.6.9).
- 2026-10-31 — Security issue disclosed (CVE-2026-118185), fixed in 1.6.9.
- 2026-08-31 — Security issue disclosed (CVE-2026-82228), fixed in 1.6.7.
- 2026-08-06 — Security issue disclosed (CVE-2026-13342), fixed in 1.6.5.
Get an email when Security Optimizer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Security Optimizer (sg-security) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/sg-security (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/sg-security"><img src="https://laskyr.com/plugins/sg-security/badge.svg" alt="Security Optimizer vulnerability status"></a>