Skip to content
Laskyr

CVE-2026-116512: Project Manager remote code execution vulnerability

critical 9.8 published 2026-10-31 · updated 2026-11-02

Fixed in Project Manager 4.1.2 (first release after the affected range)

Project Manager 4.1.1 and older is affected by this remote code execution issue. Sites on 4.1.2 or newer are not affected; the latest release is 4.1.2.

Affected versions
4.1.1 and older
Fixed in
4.1.2 *
Latest version
4.1.2
Severity
Critical · CVSS 9.8
Active installs
5,000+
Type
Remote code execution

* The source does not name a fixed version; this is the first wordpress.org release after the last affected version.

What an attacker needs

CVSS vector (score by Wordfence): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do now

  1. Update Project Manager to 4.1.2 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Project Manager issue. With WP-CLI: wp plugin get wedevs-project-manager --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Project Manager – AI Powered Project Management, Task Management, Kanban Board & Time Tracker plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.1.1 via the 'id' parameter parameter. This is due to unsanitized 'id' parameter value concatenated directly into the pipe-delimited validation rule string, which is then split and each token invoked as a dynamic PHP function with no allowlist check. This makes it possible for unauthenticated attackers to execute code on the server. This is exploitable by unauthenticated attackers because WordPress core executes the route argument's validate_callback inside WP_REST_Server::dispatch() before the route's permission_callback is invoked, meaning the Project_Manage_Capability authorization gate is never reached on the vulnerable code path.

Description from the CVE record, published by Wordfence (the CVE Numbering Authority), via the NVD entry for CVE-2026-116512.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit