Skip to content
Laskyr

CVE-2026-111737: Speed Optimizer stored cross-site scripting (XSS) vulnerability

low 3.5 published 2026-10-23

Fixed in Speed Optimizer 7.8.5

Speed Optimizer older than 7.8.5 is affected by this stored XSS issue. Sites on 7.8.5 or newer are not affected; the latest release is 7.8.5.

Affected versions
older than 7.8.5
Fixed in
7.8.5
Latest version
7.8.5
Severity
Low · CVSS 3.5
Active installs
1+ million
Type
Stored cross-site scripting (XSS)

What an attacker needs

CVSS vector (score by CISA ADP): CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N

What to do now

  1. Update Speed Optimizer to 7.8.5 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Speed Optimizer issue. With WP-CLI: wp plugin get sg-cachepress --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

The Speed Optimizer WordPress plugin before 7.8.5 does not sanitise or escape some of its settings before outputting them in the head of front-end pages, which could allow high-privilege users such as admins to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).

Description from the CVE record, published by WPScan (the CVE Numbering Authority), via the NVD entry for CVE-2026-111737.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit