Skip to content
Laskyr

Plugins · sg-cachepress · data as of 2026-11-01

Is Speed Optimizer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.8.5)

As of 2026-11-01. 5 issues are on record for older versions; version 7.8.5 or newer fixes all of them that state a fix.

Latest version
7.8.5
Last updated
2026-10-20
Active installs
1+ million
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Boost your website performance and page speed, and increase conversions with powerful caching, frontend, media, and environment optimizations. — by SiteGround

What to do

  1. Update to the latest version (7.8.5). Anything older than 7.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get sg-cachepress --field=version shows what you run; wp plugin update sg-cachepress updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

low 3.5 CVE-2026-111737 · published 2026-10-23

Stored cross-site scripting (XSS) in Speed Optimizer (older than 7.8.5)

Affected
older than 7.8.5
Fixed in
7.8.5
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Speed Optimizer WordPress plugin before 7.8.5 does not sanitise or escape some of its settings before outputting them in the head of front-end pages, which could allow high-privilege users such as admins to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).

NVD CVE-2026-111737WPScan advisory

medium 5.5 CVE-2026-111738 · published 2026-10-23

Missing authorization check in Speed Optimizer (older than 7.8.5)

Affected
older than 7.8.5
Fixed in
7.8.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Speed Optimizer WordPress plugin before 7.8.5 does not verify network-level privilege before applying an option change to the whole multisite network, nor restrict which option may be changed, allowing a site administrator who is not a Super Admin to create or overwrite network-wide options.

NVD CVE-2026-111738WPScan advisory

medium 6.4 CVE-2026-15421 · published 2026-08-19

Stored cross-site scripting (XSS) in Speed Optimizer (7.8.0 and older)

Affected
7.8.0 and older
Fixed in
7.8.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Speed Optimizer – The All-In-One Performance-Boosting Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Image Tag Attributes in all versions up to, and including, 7.8.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when the site administrator has enabled the Lazy Load Media option in the plugin settings.

NVD CVE-2026-15421Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2019-25217 · published 2024-10-16

Remote code execution in Speed Optimizer (older than 5.0.13)

Affected
older than 5.0.13
Fixed in
5.0.13
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The SiteGround Optimizer plugin for WordPress is vulnerable to authorization bypass leading to Remote Code Execution and Local File Inclusion in versions up to, and including, 5.0.12 due to incorrect use of an access control attribute on the switch_php function called via the /switch-php REST API route. This allows attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

NVD CVE-2019-25217Wordfence advisoryblog.sucuri.net

medium 5.3 CVE-2024-32532 · published 2024-04-17

Missing authorization check in Speed Optimizer (7.4.6 and older)

Affected
7.4.6 and older
Fixed in
7.5.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in SiteGround Speed Optimizer.This issue affects Speed Optimizer: from n/a through 7.4.6.

NVD CVE-2024-32532Patchstack advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Speed Optimizer vulnerability status badge
<a href="https://laskyr.com/plugins/sg-cachepress"><img src="https://laskyr.com/plugins/sg-cachepress/badge.svg" alt="Speed Optimizer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit