Skip to content
Laskyr

league/flysystem security advisory

CVE-2026-102601: Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path…

CVE-2026-102601 is a low-severity security vulnerability in the PHP package league/flysystem (CVSS 3.5), published 29 September 2026. The advisory does not name a fixed version. Exploiting it needs a low-privilege user account.

low 3.5 published 2026-09-29 · updated 2026-09-30

The advisory does not name a fixed version

This security issue affects league/flysystem versions <= 3.35.2. The newest release (3.36.0) is outside the affected range.

Affected versions
<= 3.35.2
Fixed in
not stated
Newest release
3.36.0
Severity
Low · CVSS 3.5
Type
Security issue
CWE-150
Exploited in the wild
Not on the CISA KEV list
checked 2026-11-04

Is your league/flysystem version affected?

Run composer show league/flysystem in your project, then enter the version. We check it against this and every other known league/flysystem advisory.

Who can exploit CVE-2026-102601

CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N

Your app is only exposed if it uses the affected part of league/flysystem. The advisory below says which part that is. If you are not sure, upgrade anyway: it costs less than finding out.

How to fix CVE-2026-102601 in league/flysystem

  1. Find the installed version: composer show league/flysystem. If you never required it yourself, composer why league/flysystem shows which package pulls it in.
  2. Update it: composer update league/flysystem --with-all-dependencies.
  3. If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example "league/flysystem": "^3.36.0" if you can take that version), or upgrade the package that requires it.
  4. Run composer audit. It reads the same advisory data and should no longer list CVE-2026-102601.
  5. Commit composer.lock and deploy it. On the server, run composer install --no-dev from the lock file, not composer update.

If you cannot upgrade yet

General hardening for this kind of issue while the upgrade waits. None of it replaces the fix.

The CVE-2026-102601 advisory

Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both false and 0 as falsy. A path containing malformed UTF-8 causes PCRE to return false, so paths that also contain control characters bypass CorruptedPathDetected::forPath() in normalizePath(). Filesystem::write() can store such names and Filesystem::listContents() can return the raw ANSI escape sequences, allowing hidden or spoofed terminal file listings when an administrator displays them. This issue is fixed in version 3.35.3.

Description from the CVE record, published by GitHub (the CVE Numbering Authority), via the NVD entry for CVE-2026-102601. Advisory title: “Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter”.

References

Other league/flysystem advisories

Related

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit