Skip to content
Laskyr

PHP package security

Is league/flysystem vulnerable?

2 known security advisories for league/flysystem. The latest was reported on 2026-09-29 and names no fixed version. The newest release, 3.36.0, is not affected by any of them.

1 critical 1 low

Known advisories
2
Newest release
3.36.0
Released
2026-09-02
Affecting newest release
0
Last synced
2026-11-03

File storage abstraction for PHP · packagist.org/packages/league/flysystem

Check your version

Run composer show league/flysystem in your project to see the installed version, then enter it here.

Security advisories for league/flysystem

Newest first. “Affected” is the Composer version constraint from the advisory; “fixed in” is each version the advisory names as the first safe one on its release line.

ReportedAdvisorySeverityAffectedFixed in
2026-09-29 Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter GHSA-cxf4-7mrp-vvpr · CVE-2026-102601 · GitHub low <=3.35.2 not stated
2021-06-23 TOCTOU Race Condition enabling remote code execution CVE-2021-32708 · GitHub, FriendsOfPHP/security-advisories critical <1.1.4 | >=2.0.0,<2.1.1 1.1.4, 2.1.1

Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.

Ask about a fix

Check your whole project. Paste your composer.lock and see every installed package with a known advisory. Nothing is stored.

Check composer.lock

Questions about league/flysystem

Does league/flysystem have known vulnerabilities?

Yes. Packagist lists 2 security advisories for league/flysystem (1 critical, 1 low severity). The most recent, reported 2026-09-29, is "Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter". The newest release, 3.36.0, is outside every affected range.

Which version of league/flysystem should I run?

The newest stable release is 3.36.0 (published 2026-09-02). Run composer update league/flysystem, then composer audit to confirm nothing else is flagged.

How do I check if my league/flysystem version is affected?

Run composer show league/flysystem in your project to see the installed version, then enter it in the version check on this page. You can also run composer audit, which reads the same Packagist advisory data for every package in your composer.lock.

Where this data comes from

Advisories come from the Packagist security advisories API, which collects the GitHub Advisory Database and the FriendsOfPHP security advisories. composer audit reads the same data. Releases come from packagist.org. Last synced 2026-11-03; we re-check daily. Each advisory links to its source. Spot an error? Tell us.

← All PHP packages

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit