Skip to content
Laskyr

CVE-2026-102389: Broken Link Checker remote code execution vulnerability

medium 6.5 published 2026-10-15

Fixed in Broken Link Checker 2.4.15

Broken Link Checker 2.4.14.1 and older is affected by this remote code execution issue. Sites on 2.4.15 or newer are not affected; the latest release is 2.4.15.

Affected versions
2.4.14.1 and older
Fixed in
2.4.15
Latest version
2.4.15
Severity
Medium · CVSS 6.5
Active installs
500,000+
Type
Remote code execution

What an attacker needs

CVSS vector (score by Patchstack): CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

What to do now

  1. Update Broken Link Checker to 2.4.15 or newer: Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. Not sure which version you run? Check your version against every known Broken Link Checker issue. With WP-CLI: wp plugin get broken-link-checker --field=version.
  5. If you ran an affected version and something looks off (new admin users, spam pages, redirects), run the free scan below.

The advisory

Improper Control of Generation of Code ('Code Injection') vulnerability in WPMU DEV Broken Link Checker broken-link-checker allows Code Injection.This issue affects Broken Link Checker: from n/a through 2.4.14.1.

Description from the CVE record, published by Patchstack (the CVE Numbering Authority), via the NVD entry for CVE-2026-102389.

References

Related

Ran an affected version? Check your site for signs of a hack

The free scan reads the public side of your site and looks for spam pages, hidden redirects, injected scripts and blacklist entries. No login, no install, about a minute.

Where this data comes from

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit