symfony/http-foundation security advisory
CVE-2025-64500: Incorrect parsing of PATH_INFO can lead to limited authorization bypass in symfony/http-foundation
CVE-2025-64500 is a high-severity security vulnerability in the PHP package symfony/http-foundation (CVSS 7.3), published 12 November 2025. It is fixed in 5.4.50, 6.4.29 and 7.3.7, one per release line; earlier versions on each line are affected. It can be exploited without an account.
high 7.3 published 2025-11-12 · updated 2026-10-19
- Affected versions
- >= 2.0.0, < 5.4.50
>= 6.0.0, < 6.4.29
>= 7.0.0, < 7.3.7 - Fixed in
- 5.4.50, 6.4.29, 7.3.7
- Newest release
- 8.1.10
- Severity
- High · CVSS 7.3
- Type
- Security issue
CWE-647 - Exploited in the wild
- Not on the CISA KEV list
checked 2026-11-04
Also affects
- symfony/symfony >= 2.0.0, < 5.4.50; >= 6.0.0, < 6.4.29; >= 7.0.0, < 7.3.7 fixed in 5.4.50, 6.4.29, 7.3.7
Is your symfony/http-foundation version affected?
Who can exploit CVE-2025-64500
- Access: No account. Anyone who can send a request to an app that uses the affected code.
CVSS vector (scored by GitHub): CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
How to fix CVE-2025-64500 in symfony/http-foundation
- Find the installed version:
composer show symfony/http-foundation. If you never required it yourself,composer why symfony/http-foundationshows which package pulls it in. - Update it:
composer update symfony/http-foundation --with-all-dependencies. You need the fixed version for your release line (5.4.50, 6.4.29 and 7.3.7). - If Composer will not go that high, your composer.json constraint is holding it back. Widen it (for example
"symfony/http-foundation": "^7.3.7"if you can take that version), or upgrade the package that requires it. - Run
composer audit. It reads the same advisory data and should no longer list CVE-2025-64500. - Commit composer.lock and deploy it. On the server, run
composer install --no-devfrom the lock file, notcomposer update.
If you cannot upgrade yet
- If your app does not use the affected feature, note that in your audit, but still plan the upgrade.
The CVE-2025-64500 advisory
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Symfony's HttpFoundation component defines an object-oriented layer for the HTTP specification. Starting in version 2.0.0 and prior to version 5.4.50, 6.4.29, and 7.3.7, the `Request` class improperly interprets some `PATH_INFO` in a way that leads to representing some URLs with a path that doesn't start with a `/`. This can allow bypassing some access control rules that are built with this `/`-prefix assumption. Starting in versions 5.4.50, 6.4.29, and 7.3.7, the `Request` class now ensures that URL paths always start with a `/`.
References
- GitHub security advisory GHSA-3rg7-wf37-54rm github.com
- Symfony security advisory symfony.com
- Fix commit 9962b91 github.com
- github.com github.com
- github.com github.com
Other symfony/http-foundation advisories
- high CVE-2026-108082: ReDoS in HeaderUtils::split() Reachable Through the Cache-Control Request Header 2026-09-15
- medium CVE-2026-48736: IpUtils::PRIVATE_SUBNETS Omits IPv6 Transition Forms (6to4, NAT64, Teredo, IPv4-compatible): SSRF Bypass in NoPrivateNetworkHttpClient 2026-05-26
- low CVE-2024-50345: Open redirect via browser-sanitized URLs 2024-11-05
- low CVE-2020-5255: Prevent cache poisoning via a Response Content-Type header 2020-03-30
- high CVE-2019-18888: Prevent argument injection in a MimeTypeGuesser 2019-11-13
- critical CVE-2019-10913: Reject invalid HTTP method overrides 2019-04-16
Related
Need help patching or upgrading? Laskyr does PHP and Laravel security fixes and upgrades. Tell us what you run and we reply with a plan and a price.
Ask about a fixWhere this data comes from
- Affected and fixed versions: the Packagist security advisories API (GitHub Advisory Database and FriendsOfPHP), the same data
composer audituses. Synced 2026-11-03. - Description, score, weakness and references: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Exploited-in-the-wild status: the CISA Known Exploited Vulnerabilities catalog, checked 2026-11-04.
- Compiled by Daniel Lasek at Laskyr from the sources above. The summary, “who can exploit it”, “how to fix it” and hardening sections are our plain-English reading of the record and are generated from it. The quoted description is the record's own text. Spot an error? Tell us.