Skip to content
Laskyr

Plugins · zypento-blocks · data as of 2026-11-04

Is Zypento Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.7)

As of 2026-11-04. 1 issue is on record for older versions.

Latest version
1.0.7
Last updated
2026-05-05
Active installs
fewer than 10
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Gutenberg block library. — by sproutient

What to do

  1. Update to the latest version (1.0.7). Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get zypento-blocks --field=version shows what you run; wp plugin update zypento-blocks updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.

medium 6.4 CVE-2026-5820 · published 2026-04-22

Stored cross-site scripting (XSS) in Zypento Blocks (1.06 and older)

Affected
1.06 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence

Note: the source's version range goes past the newest Zypento Blocks release on wordpress.org (1.0.7), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

The Zypento Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Table of Contents block in all versions up to, and including, 1.0.6. This is due to the front-end TOC rendering script reading heading text via `innerText` and inserting it into the page using `innerHTML` without proper sanitization. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-5820Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Zypento Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/zypento-blocks"><img src="https://laskyr.com/plugins/zypento-blocks/badge.svg" alt="Zypento Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit