Skip to content
Laskyr

Plugins · zotpress · data as of 2026-11-04

Is Zotpress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.4.5)

As of 2026-11-04. 9 issues are on record for older versions; version 7.4.5 or newer fixes all of them that state a fix.

Latest version
7.4.5
Last updated
2026-10-25
Active installs
2,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4

Zotpress displays your Zotero citations on WordPress. — by Katie

What to do

  1. Update to the latest version (7.4.5). Anything older than 7.4.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get zotpress --field=version shows what you run; wp plugin update zotpress updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-27420 · published 2026-10-08

Stored cross-site scripting (XSS) in Zotpress (7.4.4 and older)

Affected
7.4.4 and older
Fixed in
7.4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Katie Seaborn Zotpress zotpress allows Stored XSS.This issue affects Zotpress: from n/a through 7.4.4.

NVD CVE-2026-27420Patchstack advisory

medium 6.4 CVE-2025-4666 · published 2025-06-11

Stored cross-site scripting (XSS) in Zotpress (7.3.15 and older)

Affected
7.3.15 and older
Fixed in
7.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Zotpress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘nickname’ parameter in all versions up to, and including, 7.3.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-4666Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2024-7429 · published 2024-11-05

Missing authorization check in Zotpress (7.3.12 and older)

Affected
7.3.12 and older
Fixed in
7.3.13 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Zotpress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the Zotpress_process_accounts_AJAX function in all versions up to, and including, 7.3.12. This makes it possible for authenticated attackers, with Contributor-level access and above, to reset the plugin's settings.

NVD CVE-2024-7429Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-47621 · published 2024-10-05

Stored cross-site scripting (XSS) in Zotpress (7.3.10 and older)

Affected
7.3.10 and older
Fixed in
7.3.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Katie Zotpress zotpress allows Stored XSS.This issue affects Zotpress: from n/a through <= 7.3.10.

NVD CVE-2024-47621Patchstack advisory

medium 6.5 CVE-2024-34569 · published 2024-05-08

Cross-site scripting (XSS) in Zotpress (7.3.9 and older)

Affected
7.3.9 and older
Fixed in
7.3.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Katie Zotpress zotpress.This issue affects Zotpress: from n/a through <= 7.3.9.

NVD CVE-2024-34569Patchstack advisoryPatchstack advisory

high 8.8 CVE-2024-30488 · published 2024-03-29

SQL injection in Zotpress (7.3.7 and older)

Affected
7.3.7 and older
Fixed in
7.3.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Katie Zotpress zotpress.This issue affects Zotpress: from n/a through <= 7.3.7.

NVD CVE-2024-30488Patchstack advisoryPatchstack advisory

medium 6.1 CVE-2023-46313 · published 2023-10-31

Reflected cross-site scripting (XSS) in Zotpress (7.3.4 and older)

Affected
7.3.4 and older
Fixed in
7.3.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Katie Seaborn Zotpress plugin <= 7.3.4 versions.

NVD CVE-2023-46313Patchstack advisory

medium 6.1 CVE-2023-32961 · published 2023-06-12

Reflected cross-site scripting (XSS) in Zotpress (7.3.3 and older)

Affected
7.3.3 and older
Fixed in
7.3.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Katie Seaborn Zotpress plugin <= 7.3.3 versions.

NVD CVE-2023-32961Patchstack advisorylourcode.kr

critical 9.8 CVE-2016-1000217 · published 2016-10-06

SQL injection in Zotpress (6.1.2 and older)

Affected
6.1.2 and older
Fixed in
6.1.3 *
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

Zotpress plugin for WordPress SQLi in zp_get_account()

NVD CVE-2016-1000217wordpress.orgsecurityfocus.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Zotpress vulnerability status badge
<a href="https://laskyr.com/plugins/zotpress"><img src="https://laskyr.com/plugins/zotpress/badge.svg" alt="Zotpress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit