Skip to content
Laskyr

Plugins · zoho-flow · data as of 2026-11-04

Is Zoho Flow safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.14.6)

As of 2026-11-04. 5 issues are on record for older versions; version 2.14.6 or newer fixes all of them that state a fix.

Latest version
2.14.6
Last updated
2026-10-31
Active installs
5,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0.0+

Integrate your WordPress plugins with your business applications and automate workflows between them. A single platform for all your integrations. — by Zoho Flow

What to do

  1. Update to the latest version (2.14.6). Anything older than 2.14.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get zoho-flow --field=version shows what you run; wp plugin update zoho-flow updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-62131 · published 2026-10-29

PHP object injection in Zoho Flow (2.14.5 and older)

Affected
2.14.5 and older
Fixed in
2.14.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated PHP Object Injection in Zoho Flow <= 2.14.5 versions.

NVD CVE-2026-62131Patchstack advisory

medium 4.3 CVE-2025-59568 · published 2025-09-22

Cross-site request forgery (CSRF) in Zoho Flow (2.14.1 and older)

Affected
2.14.1 and older
Fixed in
2.14.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Zoho Flow Zoho Flow zoho-flow allows Cross Site Request Forgery.This issue affects Zoho Flow: from n/a through <= 2.14.1.

NVD CVE-2025-59568Patchstack advisory

medium 4.3 CVE-2025-8479 · published 2025-09-11

Cross-site request forgery (CSRF) in Zoho Flow (2.14.1 and older)

Affected
2.14.1 and older
Fixed in
2.14.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by Wordfence
Details from the advisory

The Zoho Flow plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.14.1. This is due to missing or incorrect nonce validation on the zoho_flow_deactivate_plugin function. This makes it possible for unauthenticated attackers to modify typography settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2025-8479Wordfence advisoryPlugin source

medium 4.3 CVE-2025-31408 · published 2025-04-01

Missing authorization check in Zoho Flow (2.13.3 and older)

Affected
2.13.3 and older
Fixed in
2.13.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Zoho Flow Zoho Flow zoho-flow allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Zoho Flow: from n/a through <= 2.13.3.

NVD CVE-2025-31408Patchstack advisory

high 7.6 CVE-2024-47334 · published 2024-10-09

SQL injection in Zoho Flow (2.7.1 and older)

Affected
2.7.1 and older
Fixed in
2.8.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Zoho Flow Zoho Flow zoho-flow allows SQL Injection.This issue affects Zoho Flow: from n/a through <= 2.7.1.

NVD CVE-2024-47334Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Zoho Flow vulnerability status badge
<a href="https://laskyr.com/plugins/zoho-flow"><img src="https://laskyr.com/plugins/zoho-flow/badge.svg" alt="Zoho Flow vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit