Skip to content
Laskyr

Plugins · zita-site-library · data as of 2026-11-04

Is Zita Site Library for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.7)

As of 2026-11-04. 4 issues are on record for older versions; version 1.6.7 or newer fixes all of them that state a fix.

Latest version
1.6.7
Last updated
2026-01-27
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.9.11

Using Zita Site Library for Elementor Import pre made Elementor websites in just one click install. — by wpzita

What to do

  1. Update to the latest version (1.6.7). Anything older than 1.6.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get zita-site-library --field=version shows what you run; wp plugin update zita-site-library updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-25319 · published 2026-02-19

Cross-site request forgery (CSRF) in Zita Site Library for Elementor (1.6.6 and older)

Affected
1.6.6 and older
Fixed in
1.6.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in wpzita Zita Elementor Site Library zita-site-library allows Cross Site Request Forgery.This issue affects Zita Elementor Site Library: from n/a through <= 1.6.6.

NVD CVE-2026-25319Patchstack advisory

medium 6.4 CVE-2024-8921 · published 2024-10-16

Stored cross-site scripting (XSS) in Zita Site Library for Elementor (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Zita Elementor Site Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.6.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.

NVD CVE-2024-8921Wordfence advisoryCode change (fix)wordpress.orgwpzita.comPlugin source

critical 9.9 CVE-2024-37420 · published 2024-07-09

Arbitrary file upload in Zita Site Library for Elementor (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WPZita Zita Elementor Site Library allows Upload a Web Shell to a Web Server.This issue affects Zita Elementor Site Library: from n/a through 1.6.1.

NVD CVE-2024-37420Patchstack advisory

medium 4.3 CVE-2024-3249 · published 2024-06-25

Missing authorization check in Zita Site Library for Elementor (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Zita Elementor Site Library plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the import_xml_data, xml_data_import, import_option_data, import_widgets, and import_customizer_settings functions in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to create pages, update certain options, including WooCommerce page titles and Elementor settings, import widgets, and update the plugin's customizer settings and the WordPress custom CSS. NOTE: This vulnerability was partially fixed in version 1.6.2.

NVD CVE-2024-3249Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Zita Site Library for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/zita-site-library"><img src="https://laskyr.com/plugins/zita-site-library/badge.svg" alt="Zita Site Library for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit