Skip to content
Laskyr

Plugins · zip-code-based-content-protection · data as of 2026-11-04

Is ZIP Code Based Content Protection safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.3 or newer fixes all of them that state a fix.

Latest version
1.0.3
Last updated
2026-02-19
Active installs
10+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

ZIP Code Based Content Protection comes in handy when you want the visitor to input ZIP Code before showing them any kind of content. — by PressTigers

What to do

  1. Update to the latest version (1.0.3). Anything older than 1.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get zip-code-based-content-protection --field=version shows what you run; wp plugin update zip-code-based-content-protection updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-14353 · published 2026-03-07

SQL injection in ZIP Code Based Content Protection (1.0.2 and older)

Affected
1.0.2 and older
Fixed in
1.0.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ZIP Code Based Content Protection plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 1.0.2 via the 'zipcode' parameter. This is due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-14353Wordfence advisoryCode change (fix)Plugin source

high 7.6 CVE-2025-59008 · published 2025-09-09

SQL injection in ZIP Code Based Content Protection (1.0.0 and older)

Affected
1.0.0 and older
Fixed in
1.0.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PressTigers ZIP Code Based Content Protection zip-code-based-content-protection allows SQL Injection.This issue affects ZIP Code Based Content Protection: from n/a through <= 1.0.0.

NVD CVE-2025-59008Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ZIP Code Based Content Protection vulnerability status badge
<a href="https://laskyr.com/plugins/zip-code-based-content-protection"><img src="https://laskyr.com/plugins/zip-code-based-content-protection/badge.svg" alt="ZIP Code Based Content Protection vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit