Plugins · ziggeo · data as of 2026-11-04
Is Ziggeo safe? Known vulnerabilities and latest version
- Latest version
- 3.1.2
- Last updated
- 2026-03-30
- Active installs
- 50+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 8.4+
This plugin allows you to bring video to your WordPress website or blog, through use of powerful Ziggeo API. Since we all know that video is future, m … — by oliverfriedmann
What to do
- Update to the latest version (3.1.2). Anything older than 3.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ziggeo --field=version shows what you run; wp plugin update ziggeo updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2026-4124 · published 2026-04-09
Missing authorization check in Ziggeo (3.1.1 and older)
- Affected
- 3.1.1 and older
- Fixed in
- 3.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Ziggeo plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.1.1. The wp_ajax_ziggeo_ajax handler only verifies a nonce (check_ajax_referer) but performs no capability checks via current_user_can(). Furthermore, the nonce ('ziggeo_ajax_nonce') is exposed to all logged-in users on every page via the wp_head and admin_head hooks . This makes it possible for authenticated attackers, with Subscriber-level access and above, to invoke multiple administrative operations including: saving arbitrary translation strings (translations_panel_save_strings via update_option('ziggeo_translations')), creating/updating/deleting event templates (event_editor_save_template/update_template/remove_template via update_option('ziggeo_events')), modifying SDK application settings (sdk_applications operations), and managing notifications (notification_handler via update_option('ziggeo_notifications')).
NVD CVE-2026-4124Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-12452 · published 2025-02-21
Stored cross-site scripting (XSS) in Ziggeo (3.1 and older)
- Affected
- 3.1 and older
- Fixed in
- 3.1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Ziggeo plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ziggeo_event' shortcode in all versions up to, and including, 3.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-12452Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-03-30 — latest release on wordpress.org (3.1.2).
- 2026-04-09 — Missing authorization check disclosed (CVE-2026-4124), fixed in 3.1.2.
- 2025-02-21 — Stored cross-site scripting (XSS) disclosed (CVE-2024-12452), fixed in 3.1.2.
Get an email when Ziggeo has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ziggeo (ziggeo) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ziggeo (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ziggeo"><img src="https://laskyr.com/plugins/ziggeo/badge.svg" alt="Ziggeo vulnerability status"></a>