Plugins · zigaform-calculator-cost-estimation-form-builder-lite · data as of 2026-11-04
Is Zigaform safe? Known vulnerabilities and latest version
- Latest version
- 7.7.20
- Last updated
- 2026-08-25
- Active installs
- 100+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Create estimation forms using this powerful drag-and-drop estimation form builder, enabling you to build forms in just a few minutes. — by softdiscover
What to do
- Update to the latest version (7.7.20). Anything older than 7.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get zigaform-calculator-cost-estimation-form-builder-lite --field=version shows what you run; wp plugin update zigaform-calculator-cost-estimation-form-builder-lite updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-13696 · published 2025-12-02
Information disclosure in Zigaform (7.6.5 and older)
- Affected
- 7.6.5 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Zigaform plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 7.6.5. This is due to the plugin exposing a public AJAX endpoint that retrieves form submission data without performing authorization checks to verify ownership or access rights. This makes it possible for unauthenticated attackers to extract sensitive form submission data including personal information, payment details, and other private data via the rocket_front_payment_seesummary action by enumerating sequential form_r_id values.
NVD CVE-2025-13696Wordfence advisoryCode change (fix)github.comPlugin source
medium 6.1 CVE-2025-26994 · published 2025-03-03
Stored cross-site scripting (XSS) in Zigaform (7.4.2 and older)
- Affected
- 7.4.2 and older
- Fixed in
- 7.4.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in softdiscover Zigaform – Price Calculator & Cost Estimation Form Builder Lite zigaform-calculator-cost-estimation-form-builder-lite allows Stored XSS.This issue affects Zigaform – Price Calculator & Cost Estimation Form Builder Lite: from n/a through <= 7.4.2.
medium 5.4 CVE-2024-13587 · published 2025-02-18
Stored cross-site scripting (XSS) in Zigaform (7.4.7 and older)
- Affected
- 7.4.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Zigaform – Price Calculator & Cost Estimation Form Builder Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'zgfm_fvar' shortcode in all versions up to, and including, 7.4.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-08-25 — latest release on wordpress.org (7.7.20).
- 2025-12-02 — Information disclosure disclosed (CVE-2025-13696), fix version not stated.
- 2025-03-03 — Stored cross-site scripting (XSS) disclosed (CVE-2025-26994), fixed in 7.4.3.
- 2025-02-18 — Stored cross-site scripting (XSS) disclosed (CVE-2024-13587), fix version not stated.
Get an email when Zigaform has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Zigaform (zigaform-calculator-cost-estimation-form-builder-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/zigaform-calculator-cost-estimation-form-builder-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/zigaform-calculator-cost-estimation-form-builder-lite"><img src="https://laskyr.com/plugins/zigaform-calculator-cost-estimation-form-builder-lite/badge.svg" alt="Zigaform vulnerability status"></a>