Skip to content
Laskyr

Plugins · ysleadgen · data as of 2026-11-04

Is YS LeadGen safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.5 or newer fixes all of them that state a fix.

Latest version
2.3.1
Last updated
2026-10-31
Active installs
10+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create exit intent popups, email optin forms, contact forms, floating bars, spin wheels & WooCommerce popups with a drag and drop lead builder. — by YS Innovations

What to do

  1. Update to the latest version (2.3.1). Anything older than 2.1.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ysleadgen --field=version shows what you run; wp plugin update ysleadgen updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-1255 · published 2026-09-19

Information disclosure in YS LeadGen (2.1.4 and older)

Affected
2.1.4 and older
Fixed in
2.1.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YS LeadGen plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.1.4 due to the 'ysleadgen_get_captured_data' AJAX action being accessible to unauthenticated users. This makes it possible for unauthenticated attackers to retrieve all captured form submission data, including personally identifiable information (PII) such as names, email addresses, and message content submitted through YS LeadGen forms.

NVD CVE-2026-1255Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2026-1256 · published 2026-09-19

Stored cross-site scripting (XSS) in YS LeadGen (2.1.4 and older)

Affected
2.1.4 and older
Fixed in
2.1.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YS LeadGen plugin for WordPress is vulnerable to authorization bypass and Stored Cross-Site Scripting via multiple AJAX endpoints in all versions up to, and including, 2.1.4 due to missing capability checks on popup management actions. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create arbitrary popups and inject malicious JavaScript that executes when the popup is displayed, leading to Stored XSS.

NVD CVE-2026-1256Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YS LeadGen vulnerability status badge
<a href="https://laskyr.com/plugins/ysleadgen"><img src="https://laskyr.com/plugins/ysleadgen/badge.svg" alt="YS LeadGen vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit