Plugins · youtube-embed · data as of 2026-11-04
Is Embeds for YouTube safe? Known vulnerabilities and latest version
- Latest version
- 5.4
- Last updated
- 2025-04-18
- Active installs
- 9,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12 · PHP 7.4+
🎥 An incredibly fast, simple, yet powerful, method of embedding YouTube videos into your WordPress site. — by Embeds For YouTube Plugin Support
What to do
- There is no fixed version yet. If you can live without Embeds for YouTube for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get youtube-embed --field=version shows what you run; wp plugin update youtube-embed updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 5.4 CVE-2025-68599 · published 2025-12-24
Stored cross-site scripting (XSS) in Embeds for YouTube (5.4 and older)
- Affected
- 5.4 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Embeds For YouTube Plugin Support YouTube Embed youtube-embed allows Stored XSS.This issue affects YouTube Embed: from n/a through <= 5.4.
medium 5.9 CVE-2025-31008 · published 2025-04-09
Stored cross-site scripting (XSS) in Embeds for YouTube (5.3.1 and older)
- Affected
- 5.3.1 and older
- Fixed in
- 5.4
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Embeds For YouTube Plugin Support YouTube Embed youtube-embed allows Stored XSS.This issue affects YouTube Embed: from n/a through <= 5.3.1.
low 3.5 CVE-2015-6535 · published 2015-08-31
Cross-site scripting (XSS) in Embeds for YouTube (3.3.2 and older)
- Affected
- 3.3.2 and older
- Fixed in
- 3.3.5 *
- Range from
- NVD analysis · score by NVD
Details from the advisory
Cross-site scripting (XSS) vulnerability in includes/options-profiles.php in the YouTube Embed plugin before 3.3.3 for WordPress allows remote administrators to inject arbitrary web script or HTML via the Profile name field (youtube_embed_name parameter).
NVD CVE-2015-6535wordpress.orgpacketstormsecurity.comsecurityfocus.comwpvulndb.com
Recent activity
- 2025-04-18 — latest release on wordpress.org (5.4).
- 2025-12-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-68599), no fix listed yet.
- 2025-04-09 — Stored cross-site scripting (XSS) disclosed (CVE-2025-31008), fixed in 5.4.
- 2015-08-31 — Cross-site scripting (XSS) disclosed (CVE-2015-6535), fixed in 3.3.5.
Get an email when Embeds for YouTube has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Embeds for YouTube (youtube-embed) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/youtube-embed (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/youtube-embed"><img src="https://laskyr.com/plugins/youtube-embed/badge.svg" alt="Embeds for YouTube vulnerability status"></a>