Skip to content
Laskyr

Plugins · yookassa · data as of 2026-11-04

Is ЮKassa для WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.17.4)

As of 2026-11-04. 5 issues are on record for older versions; version 2.17.4 or newer fixes all of them that state a fix.

Latest version
2.17.4
Last updated
2026-11-03
Active installs
9,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6.20+

Прием платежей на сайтах WooCommerce. Разработка и поддержка — компания ЮMoney — by yoomoney

What to do

  1. Update to the latest version (2.17.4). Anything older than 2.17.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yookassa --field=version shows what you run; wp plugin update yookassa updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-114699 · published 2026-10-22

Missing authorization check in ЮKassa для WooCommerce (2.17.3 and older)

Affected
2.17.3 and older
Fixed in
2.17.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in yoomoney ЮKassa для WooCommerce yookassa allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ЮKassa для WooCommerce: from n/a through 2.17.3.

NVD CVE-2026-114699Patchstack advisory

medium 6.5 CVE-2026-65434 · published 2026-07-27

Information disclosure in ЮKassa для WooCommerce (2.16.1 and older)

Affected
2.16.1 and older
Fixed in
2.16.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in ЮKassa для WooCommerce <= 2.16.1 versions.

NVD CVE-2026-65434Patchstack advisory

medium 4.3 CVE-2026-65457 · published 2026-07-23

Missing authorization check in ЮKassa для WooCommerce (2.16.1 and older)

Affected
2.16.1 and older
Fixed in
2.16.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in ЮKassa для WooCommerce <= 2.16.1 versions.

NVD CVE-2026-65457Patchstack advisory

high 8.8 CVE-2022-36379 · published 2022-08-23

Cross-site request forgery (CSRF) in ЮKassa для WooCommerce (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) leading to plugin settings update in YooMoney ЮKassa для WooCommerce plugin <= 2.3.0 at WordPress.

NVD CVE-2022-36379Patchstack advisorywordpress.org

medium 6.5 CVE-2022-34868 · published 2022-08-23

Security issue in ЮKassa для WooCommerce (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated Arbitrary Settings Update vulnerability in YooMoney ЮKassa для WooCommerce plugin <= 2.3.0 at WordPress.

NVD CVE-2022-34868Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ЮKassa для WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/yookassa"><img src="https://laskyr.com/plugins/yookassa/badge.svg" alt="ЮKassa для WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit