Plugins · yoco-payment-gateway · data as of 2026-11-04
Is Yoco Payments safe? Known vulnerabilities and latest version
- Latest version
- 3.9.5
- Last updated
- 2026-10-05
- Active installs
- 10,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4.0+
The Yoco Payments plugin lets you easily accept payments via Yoco Payments on your WooCommerce WordPress site. — by yocoadmin
What to do
- Update to the latest version (3.9.5). Anything older than 3.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yoco-payment-gateway --field=version shows what you run; wp plugin update yoco-payment-gateway updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2025-13801 · published 2026-01-07
Path traversal / file read in Yoco Payments (3.9.0 and older)
- Affected
- 3.9.0 and older
- Fixed in
- 3.9.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Yoco Payments plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 3.9.0 via the file parameter. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information.
NVD CVE-2025-13801Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-05 — latest release on wordpress.org (3.9.5).
- 2026-01-07 — Path traversal / file read disclosed (CVE-2025-13801), fixed in 3.9.1.
Get an email when Yoco Payments has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Yoco Payments (yoco-payment-gateway) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Path traversal and file read (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yoco-payment-gateway (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yoco-payment-gateway"><img src="https://laskyr.com/plugins/yoco-payment-gateway/badge.svg" alt="Yoco Payments vulnerability status"></a>