Skip to content
Laskyr

Plugins · yith-woocommerce-quick-view · data as of 2026-11-04

Is YITH WooCommerce Quick View safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.19.0)

As of 2026-11-04. 1 issue is on record for older versions; version 2.7.1 or newer fixes all of them that state a fix.

Latest version
2.19.0
Last updated
2026-10-07
Active installs
80,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

This plugin adds the possibility to have a quick preview of the products right from product list — by YITHEMES

What to do

  1. Update to the latest version (2.19.0). Anything older than 2.7.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yith-woocommerce-quick-view --field=version shows what you run; wp plugin update yith-woocommerce-quick-view updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-8617 · published 2025-12-13

Stored cross-site scripting (XSS) in YITH WooCommerce Quick View (2.7.0 and older)

Affected
2.7.0 and older
Fixed in
2.7.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YITH WooCommerce Quick View plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's yith_quick_view shortcode in all versions up to, and including, 2.7.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-8617Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YITH WooCommerce Quick View vulnerability status badge
<a href="https://laskyr.com/plugins/yith-woocommerce-quick-view"><img src="https://laskyr.com/plugins/yith-woocommerce-quick-view/badge.svg" alt="YITH WooCommerce Quick View vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit