Skip to content
Laskyr

Plugins · yith-woocommerce-product-add-ons · data as of 2026-11-04

Is YITH WooCommerce Product Add-Ons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.35.0)

As of 2026-11-04. 9 issues are on record for older versions; version 4.34.1 or newer fixes all of them that state a fix.

Latest version
4.35.0
Last updated
2026-11-03
Active installs
20,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

Increase average order value by letting your customers purchase additional options on your products. — by YITHEMES

What to do

  1. Update to the latest version (4.35.0). Anything older than 4.34.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yith-woocommerce-product-add-ons --field=version shows what you run; wp plugin update yith-woocommerce-product-add-ons updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-107868 · published 2026-10-30

Missing authorization check in YITH WooCommerce Product Add-Ons (4.34.0 and older)

Affected
4.34.0 and older
Fixed in
4.34.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Bypass Vulnerability in YITH WooCommerce Product Add-Ons <= 4.34.0 versions.

NVD CVE-2026-107868Patchstack advisory

medium 5.3 CVE-2026-66480 · published 2026-10-10

Information disclosure in YITH WooCommerce Product Add-Ons (4.34.0 and older)

Affected
4.34.0 and older
Fixed in
4.34.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in YITH YITH WooCommerce Product Add-Ons allows Retrieve Embedded Sensitive Data. This issue affects YITH WooCommerce Product Add-Ons: from n/a through 4.34.0.

NVD CVE-2026-66480Patchstack advisory

high 7.6 CVE-2026-42383 · published 2026-05-20

SQL injection in YITH WooCommerce Product Add-Ons (4.29.0 and older)

Affected
4.29.0 and older
Fixed in
4.29.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YITH YITH WooCommerce Product Add-Ons allows Blind SQL Injection. This issue affects YITH WooCommerce Product Add-Ons: from n/a through 4.29.0.

NVD CVE-2026-42383Patchstack advisory

medium 5.3 CVE-2023-46635 · published 2025-01-02

Missing authorization check in YITH WooCommerce Product Add-Ons (4.2.0 and older)

Affected
4.2.0 and older
Fixed in
4.2.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in YITHEMES YITH WooCommerce Product Add-Ons yith-woocommerce-product-add-ons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YITH WooCommerce Product Add-Ons: from n/a through <= 4.2.0.

NVD CVE-2023-46635Patchstack advisory

medium 6.1 CVE-2024-50448 · published 2024-10-28

Cross-site scripting (XSS) in YITH WooCommerce Product Add-Ons (4.14.1 and older)

Affected
4.14.1 and older
Fixed in
4.14.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in YITHEMES YITH WooCommerce Product Add-Ons yith-woocommerce-product-add-ons.This issue affects YITH WooCommerce Product Add-Ons: from n/a through <= 4.14.1.

NVD CVE-2024-50448Patchstack advisory

high 7.1 CVE-2024-47367 · published 2024-10-06

Reflected cross-site scripting (XSS) in YITH WooCommerce Product Add-Ons (4.13.0 and older)

Affected
4.13.0 and older
Fixed in
4.13.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in YITHEMES YITH WooCommerce Product Add-Ons yith-woocommerce-product-add-ons allows Reflected XSS.This issue affects YITH WooCommerce Product Add-Ons: from n/a through <= 4.13.0.

NVD CVE-2024-47367Patchstack advisory

medium 5.3 CVE-2024-35680 · published 2024-06-10

Cross-site scripting (XSS) in YITH WooCommerce Product Add-Ons (4.9.2 and older)

Affected
4.9.2 and older
Fixed in
4.9.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in YITHEMES YITH WooCommerce Product Add-Ons yith-woocommerce-product-add-ons.This issue affects YITH WooCommerce Product Add-Ons: from n/a through <= 4.9.2.

NVD CVE-2024-35680Patchstack advisoryPatchstack advisory

high 7.1 CVE-2024-27994 · published 2024-03-21

Cross-site scripting (XSS) in YITH WooCommerce Product Add-Ons (4.5.0 and older)

Affected
4.5.0 and older
Fixed in
4.6.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in YITHEMES YITH WooCommerce Product Add-Ons yith-woocommerce-product-add-ons.This issue affects YITH WooCommerce Product Add-Ons: from n/a through <= 4.5.0.

NVD CVE-2024-27994Patchstack advisoryPatchstack advisory

high 8.8 CVE-2023-49777 · published 2023-12-31

PHP object injection in YITH WooCommerce Product Add-Ons (4.3.0 and older)

Affected
4.3.0 and older
Fixed in
4.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Deserialization of Untrusted Data vulnerability in YITH YITH WooCommerce Product Add-Ons.This issue affects YITH WooCommerce Product Add-Ons: from n/a through 4.3.0.

NVD CVE-2023-49777Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YITH WooCommerce Product Add-Ons vulnerability status badge
<a href="https://laskyr.com/plugins/yith-woocommerce-product-add-ons"><img src="https://laskyr.com/plugins/yith-woocommerce-product-add-ons/badge.svg" alt="YITH WooCommerce Product Add-Ons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit