Skip to content
Laskyr

Plugins · yith-woocommerce-compare · data as of 2026-11-04

Is YITH WooCommerce Compare safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.16.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.15.1 or newer fixes all of them that state a fix.

Latest version
3.16.0
Last updated
2026-11-03
Active installs
100,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

YITH WooCommerce Compare allows you to compare more products of your shop in one complete table. WooCommerce Compatible up to 11.3 — by YITHEMES

What to do

  1. Update to the latest version (3.16.0). Anything older than 3.15.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yith-woocommerce-compare --field=version shows what you run; wp plugin update yith-woocommerce-compare updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-106604 · published 2026-10-15

Stored cross-site scripting (XSS) in YITH WooCommerce Compare (3.15.0 and older)

Affected
3.15.0 and older
Fixed in
3.15.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in YITH YITH WooCommerce Compare yith-woocommerce-compare allows Stored XSS.This issue affects YITH WooCommerce Compare: from n/a through 3.15.0.

NVD CVE-2026-106604Patchstack advisory

high 7.2 CVE-2026-22333 · published 2026-02-19

PHP object injection in YITH WooCommerce Compare (3.6.0 and older)

Affected
3.6.0 and older
Fixed in
3.7.0
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in YITHEMES YITH WooCommerce Compare yith-woocommerce-compare allows Object Injection.This issue affects YITH WooCommerce Compare: from n/a through <= 3.6.0.

NVD CVE-2026-22333Patchstack advisory

medium 4.3 CVE-2024-32699 · published 2024-04-24

Cross-site request forgery (CSRF) in YITH WooCommerce Compare (2.37.0 and older)

Affected
2.37.0 and older
Fixed in
2.38.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in YITHEMES YITH WooCommerce Compare yith-woocommerce-compare.This issue affects YITH WooCommerce Compare: from n/a through <= 2.37.0.

NVD CVE-2024-32699Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YITH WooCommerce Compare vulnerability status badge
<a href="https://laskyr.com/plugins/yith-woocommerce-compare"><img src="https://laskyr.com/plugins/yith-woocommerce-compare/badge.svg" alt="YITH WooCommerce Compare vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit