Skip to content
Laskyr

Plugins · yith-woocommerce-ajax-search · data as of 2026-11-04

Is YITH WooCommerce Ajax Search safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.30.0)

As of 2026-11-04. 4 issues are on record for older versions; version 2.28.1 or newer fixes all of them that state a fix.

Latest version
2.30.0
Last updated
2026-10-29
Active installs
30,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

YITH WooCommerce Ajax Search allows your users to search products in real time. — by YITHEMES

What to do

  1. Update to the latest version (2.30.0). Anything older than 2.28.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yith-woocommerce-ajax-search --field=version shows what you run; wp plugin update yith-woocommerce-ajax-search updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-96352 · published 2026-09-30

Cross-site scripting (XSS) in YITH WooCommerce Ajax Search (2.28.0 and older)

Affected
2.28.0 and older
Fixed in
2.28.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in YITH WooCommerce Ajax Search <= 2.28.0 versions.

NVD CVE-2026-96352Patchstack advisory

critical 9.3 CVE-2024-47350 · published 2024-10-06

SQL injection in YITH WooCommerce Ajax Search (2.8.0 and older)

Affected
2.8.0 and older
Fixed in
2.8.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YITHEMES YITH WooCommerce Ajax Search yith-woocommerce-ajax-search.This issue affects YITH WooCommerce Ajax Search: from n/a through <= 2.8.0.

NVD CVE-2024-47350Patchstack advisory

medium 5.4 CVE-2024-7846 · published 2024-09-23

Cross-site scripting (XSS) in YITH WooCommerce Ajax Search (older than 2.7.1)

Affected
older than 2.7.1
Fixed in
2.7.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

YITH WooCommerce Ajax Search is vulnerable to a XSS vulnerability due to insufficient sanitization of user supplied block attributes. This makes it possible for Contributors+ attackers to inject arbitrary scripts.

NVD CVE-2024-7846WPScan advisory

medium 6.1 CVE-2024-4455 · published 2024-05-24

Stored cross-site scripting (XSS) in YITH WooCommerce Ajax Search (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The YITH WooCommerce Ajax Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘item’ parameter in versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4455Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YITH WooCommerce Ajax Search vulnerability status badge
<a href="https://laskyr.com/plugins/yith-woocommerce-ajax-search"><img src="https://laskyr.com/plugins/yith-woocommerce-ajax-search/badge.svg" alt="YITH WooCommerce Ajax Search vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit