Plugins · yith-paypal-express-checkout-for-woocommerce · data as of 2026-11-04
Is YITH PayPal Express Checkout for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.63.0
- Last updated
- 2026-10-28
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Make payments immediate with PayPal Express Checkout and forget about customers’ complaints about pending orders. — by YITHEMES
What to do
- Update to the latest version (1.63.0). Anything older than 1.62.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yith-paypal-express-checkout-for-woocommerce --field=version shows what you run; wp plugin update yith-paypal-express-checkout-for-woocommerce updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-27401 · published 2026-10-29
Missing authorization check in YITH PayPal Express Checkout for WooCommerce (1.62.0 and older)
- Affected
- 1.62.0 and older
- Fixed in
- 1.62.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in YITH YITH PayPal Express Checkout for WooCommerce yith-paypal-express-checkout-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YITH PayPal Express Checkout for WooCommerce: from n/a through 1.62.0.
medium 5.3 CVE-2026-111409 · published 2026-10-16
Missing authorization check in YITH PayPal Express Checkout for WooCommerce (1.61.0 and older)
- Affected
- 1.61.0 and older
- Fixed in
- 1.62.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in YITH YITH PayPal Express Checkout for WooCommerce yith-paypal-express-checkout-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YITH PayPal Express Checkout for WooCommerce: from n/a through 1.61.0.
medium 4.3 CVE-2025-48111 · published 2025-06-17
Cross-site request forgery (CSRF) in YITH PayPal Express Checkout for WooCommerce (1.49.0 and older)
- Affected
- 1.49.0 and older
- Fixed in
- 1.49.1
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in YITHEMES YITH PayPal Express Checkout for WooCommerce allows Cross Site Request Forgery. This issue affects YITH PayPal Express Checkout for WooCommerce: from n/a through 1.49.0.
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.63.0).
- 2026-10-29 — Missing authorization check disclosed (CVE-2026-27401), fixed in 1.62.1.
- 2026-10-16 — Missing authorization check disclosed (CVE-2026-111409), fixed in 1.62.0.
- 2025-06-17 — Cross-site request forgery (CSRF) disclosed (CVE-2025-48111), fixed in 1.49.1.
Get an email when YITH PayPal Express Checkout for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for YITH PayPal Express Checkout for WooCommerce (yith-paypal-express-checkout-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by YITHEMES (13 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yith-paypal-express-checkout-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yith-paypal-express-checkout-for-woocommerce"><img src="https://laskyr.com/plugins/yith-paypal-express-checkout-for-woocommerce/badge.svg" alt="YITH PayPal Express Checkout for WooCommerce vulnerability status"></a>