Plugins · yaypricing · data as of 2026-11-04
Is YayPricing safe? Known vulnerabilities and latest version
- Latest version
- 3.6.2
- Last updated
- 2026-10-30
- Active installs
- 3,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.7+
Your all-in-one WooCommerce dynamic pricing toolkit. From Buy X Get Y to tiered and bundle discounts, create powerful rules that boost sales with ease … — by YayCommerce
What to do
- Update to the latest version (3.6.2). Anything older than 3.5.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yaypricing --field=version shows what you run; wp plugin update yaypricing updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.0 CVE-2026-87888 · published 2026-09-12
Cross-site scripting (XSS) in YayPricing (older than 3.5.7)
- Affected
- older than 3.5.7
- Fixed in
- 3.5.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The YayPricing WordPress plugin before 3.5.7 does not perform an authorization check on a REST route that saves its pricing rules, allowing users with the subscriber role and above to store JavaScript that executes in the browser of an administrator who opens the YayPricing WordPress plugin before 3.5.7's settings page.
high 8.1 CVE-2026-15230 · published 2026-08-05
Missing authorization check in YayPricing (older than 3.5.7)
- Affected
- older than 3.5.7
- Fixed in
- 3.5.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The YayPricing WordPress plugin before 3.5.7 does not perform capability checks on several of its REST API routes, relying only on a shared nonce, allowing any authenticated user such as a subscriber to overwrite the store's pricing configuration and to disclose private coupon codes.
medium 5.4 CVE-2026-66442 · published 2026-07-27
Missing authorization check in YayPricing (3.5.6 and older)
- Affected
- 3.5.6 and older
- Fixed in
- 3.5.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in YayPricing <= 3.5.6 versions.
high 7.5 CVE-2025-60077 · published 2025-12-18
Missing authorization check in YayPricing (3.5.3 and older)
- Affected
- 3.5.3 and older
- Fixed in
- 3.5.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in YayCommerce YayPricing yaypricing allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects YayPricing: from n/a through <= 3.5.3.
Recent activity
- 2026-10-30 — latest release on wordpress.org (3.6.2).
- 2026-09-12 — Cross-site scripting (XSS) disclosed (CVE-2026-87888), fixed in 3.5.7.
- 2026-08-05 — Missing authorization check disclosed (CVE-2026-15230), fixed in 3.5.7.
- 2026-07-27 — Missing authorization check disclosed (CVE-2026-66442), fixed in 3.5.7.
Get an email when YayPricing has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for YayPricing (yaypricing) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by YayCommerce (4 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yaypricing (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yaypricing"><img src="https://laskyr.com/plugins/yaypricing/badge.svg" alt="YayPricing vulnerability status"></a>