Skip to content
Laskyr

Plugins · yaymail · data as of 2026-11-04

Is YayMail safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.8)

As of 2026-11-04. 8 issues are on record for older versions; version 4.4.7 or newer fixes all of them that state a fix.

Latest version
4.4.8
Last updated
2026-10-30
Active installs
50,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.4+

Customize WooCommerce email templates with an advanced drag-and-drop email builder. Works great with 80+ WooCommerce Email Customizer Addons. — by YayCommerce

What to do

  1. Update to the latest version (4.4.8). Anything older than 4.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yaymail --field=version shows what you run; wp plugin update yaymail updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-42701 · published 2026-10-29

PHP object injection in YayMail (4.4.6 and older)

Affected
4.4.6 and older
Fixed in
4.4.7
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in YayMail <= 4.4.6 versions.

NVD CVE-2026-42701Patchstack advisory

high 7.2 CVE-2026-39498 · published 2026-06-15

PHP object injection in YayMail (4.3.3 and older)

Affected
4.3.3 and older
Fixed in
4.3.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Shop manager PHP Object Injection in YayMail <= 4.3.3 versions.

NVD CVE-2026-39498Patchstack advisory

high 7.6 CVE-2026-39496 · published 2026-04-08

SQL injection in YayMail (4.3.3 and older)

Affected
4.3.3 and older
Fixed in
4.3.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in YayCommerce YayMail yaymail allows Blind SQL Injection.This issue affects YayMail: from n/a through <= 4.3.3.

NVD CVE-2026-39496Patchstack advisory

medium 4.3 CVE-2026-27327 · published 2026-02-19

Missing authorization check in YayMail (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in YayCommerce YayMail yaymail allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects YayMail: from n/a through <= 4.3.2.

NVD CVE-2026-27327Patchstack advisory

medium 5.3 CVE-2026-1938 · published 2026-02-18

Missing authorization check in YayMail (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YayMail – WooCommerce Email Customizer plugin for WordPress is vulnerable to unauthorized license key deletion due to a missing authorization check on the `/yaymail-license/v1/license/delete` REST endpoint in versions up to, and including, 4.3.2. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to delete the plugin's license key via the '/yaymail-license/v1/license/delete' endpoint granted they can obtain the REST API nonce.

NVD CVE-2026-1938Wordfence advisoryCode change (fix)Plugin source

medium 4.4 CVE-2026-1943 · published 2026-02-18

Stored cross-site scripting (XSS) in YayMail (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YayMail – WooCommerce Email Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via settings in all versions up to, and including, 4.3.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Shop Manager-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-1943Wordfence advisoryCode change (fix)Plugin source

low 2.7 CVE-2026-1831 · published 2026-02-18

Missing authorization check in YayMail (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YayMail - WooCommerce Email Customizer plugin for WordPress is vulnerable to unauthorized plugin installation and activation due to missing capability checks on the 'yaymail_install_yaysmtp' AJAX action and `/yaymail/v1/addons/activate` REST endpoint in all versions up to, and including, 4.3.2. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to install and activate the YaySMTP plugin.

NVD CVE-2026-1831Wordfence advisoryCode change (fix)Plugin source

high 7.2 CVE-2026-1937 · published 2026-02-18

Privilege escalation in YayMail (4.3.2 and older)

Affected
4.3.2 and older
Fixed in
4.3.3 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YayMail – WooCommerce Email Customizer plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the `yaymail_import_state` AJAX action in all versions up to, and including, 4.3.2. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.

NVD CVE-2026-1937Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YayMail vulnerability status badge
<a href="https://laskyr.com/plugins/yaymail"><img src="https://laskyr.com/plugins/yaymail/badge.svg" alt="YayMail vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit