Skip to content
Laskyr

Plugins · yamaps · data as of 2026-11-04

Is YaMaps for WordPress Plugin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.6.41)

As of 2026-11-04. 4 issues are on record for older versions; version 0.6.41 or newer fixes all of them that state a fix.

Latest version
0.6.41
Last updated
2026-10-16
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

The plugin allows you to add Yandex Maps (Яндекс Карты) to pages of your site using a WordPress visual editor. — by Yuri Baranov

What to do

  1. Update to the latest version (0.6.41). Anything older than 0.6.41 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yamaps --field=version shows what you run; wp plugin update yamaps updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14851 · published 2026-02-19

Stored cross-site scripting (XSS) in YaMaps for WordPress Plugin (0.6.40 and older)

Affected
0.6.40 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The YaMaps for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `yamap` shortcode parameters in all versions up to, and including, 0.6.40 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-14851Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2025-13958 · published 2025-12-29

Stored cross-site scripting (XSS) in YaMaps for WordPress Plugin (older than 0.6.40)

Affected
older than 0.6.40
Fixed in
0.6.40
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The YaMaps for WordPress Plugin WordPress plugin before 0.6.40 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2025-13958WPScan advisory

medium 6.5 CVE-2025-32172 · published 2025-04-04

Stored cross-site scripting (XSS) in YaMaps for WordPress Plugin (0.6.40 and older)

Affected
0.6.40 and older
Fixed in
0.6.41
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Yuri Baranov YaMaps for WordPress yamaps allows Stored XSS.This issue affects YaMaps for WordPress: from n/a through <= 0.6.40.

NVD CVE-2025-32172Patchstack advisory

medium 6.5 CVE-2024-43224 · published 2024-08-12

Stored cross-site scripting (XSS) in YaMaps for WordPress Plugin (0.6.27 and older)

Affected
0.6.27 and older
Fixed in
0.6.28 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Yuri Baranov YaMaps for WordPress allows Stored XSS.This issue affects YaMaps for WordPress: from n/a through 0.6.27.

NVD CVE-2024-43224Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
YaMaps for WordPress Plugin vulnerability status badge
<a href="https://laskyr.com/plugins/yamaps"><img src="https://laskyr.com/plugins/yamaps/badge.svg" alt="YaMaps for WordPress Plugin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit