Skip to content
Laskyr

Plugins · yada-wiki · data as of 2026-11-04

Is Yada Wiki safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6)

As of 2026-11-04. 2 issues are on record for older versions; version 3.6 or newer fixes all of them that state a fix.

Latest version
3.6
Last updated
2025-11-22
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11

Yada Wiki is a simple wiki for your WordPress site. — by dmccan

What to do

  1. Update to the latest version (3.6). Anything older than 3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get yada-wiki --field=version shows what you run; wp plugin update yada-wiki updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-66094 · published 2025-12-30

Stored cross-site scripting (XSS) in Yada Wiki (3.5 and older)

Affected
3.5 and older
Fixed in
3.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in dmccan Yada Wiki yada-wiki allows Stored XSS.This issue affects Yada Wiki: from n/a through <= 3.5.

NVD CVE-2025-66094Patchstack advisory

medium 5.4 CVE-2021-24470 · published 2021-08-02

Stored cross-site scripting (XSS) in Yada Wiki (older than 3.4.1)

Affected
older than 3.4.1
Fixed in
3.4.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Yada Wiki WordPress plugin before 3.4.1 did not sanitise, validate or escape the anchor attribute of its shortcode, leading to a Stored Cross-Site Scripting issue

NVD CVE-2021-24470WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Yada Wiki vulnerability status badge
<a href="https://laskyr.com/plugins/yada-wiki"><img src="https://laskyr.com/plugins/yada-wiki/badge.svg" alt="Yada Wiki vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit