Plugins · yaad-sarig-payment-gateway-for-wc · data as of 2026-11-04
Is Yaad Sarig Payment Gateway For WC safe? Known vulnerabilities and latest version
- Latest version
- 2.2.14
- Last updated
- 2026-11-02
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.4+
Allows receiving payments via Hyp Payments ( YaadPay ) תוסף סליקה לווקומרס - Hyp Payments — by yaadsarig
What to do
- Update to the latest version (2.2.14). Anything older than 2.2.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get yaad-sarig-payment-gateway-for-wc --field=version shows what you run; wp plugin update yaad-sarig-payment-gateway-for-wc updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-104651 · published 2026-10-07
Missing authorization check in Yaad Sarig Payment Gateway For WC (older than 2.2.13)
- Affected
- older than 2.2.13
- Fixed in
- 2.2.13
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Yaad Sarig Payment Gateway For WC WordPress plugin before 2.2.13 does not verify authorization or that the requesting user owns the target order in several of its order payment-processing actions, allowing any authenticated user, including subscribers, to act on and alter orders belonging to other customers.
medium 5.3 CVE-2025-66131 · published 2025-12-16
Missing authorization check in Yaad Sarig Payment Gateway For WC (2.2.11 and older)
- Affected
- 2.2.11 and older
- Fixed in
- 2.2.12 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in yaadsarig Yaad Sarig Payment Gateway For WC yaad-sarig-payment-gateway-for-wc allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Yaad Sarig Payment Gateway For WC: from n/a through <= 2.2.11.
medium 5.4 CVE-2024-10665 · published 2024-11-20
Missing authorization check in Yaad Sarig Payment Gateway For WC (2.2.4 and older)
- Affected
- 2.2.4 and older
- Fixed in
- 2.2.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Yaad Sarig Payment Gateway For WC plugin for WordPress is vulnerable to unauthorized modification & access of data due to a missing capability check on the yaadpay_view_log_callback() and yaadpay_delete_log_callback() functions in all versions up to, and including, 2.2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to view and delete logs.
NVD CVE-2024-10665Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.2.14).
- 2026-10-07 — Missing authorization check disclosed (CVE-2026-104651), fixed in 2.2.13.
- 2025-12-16 — Missing authorization check disclosed (CVE-2025-66131), fixed in 2.2.12.
- 2024-11-20 — Missing authorization check disclosed (CVE-2024-10665), fixed in 2.2.5.
Get an email when Yaad Sarig Payment Gateway For WC has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Yaad Sarig Payment Gateway For WC (yaad-sarig-payment-gateway-for-wc) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/yaad-sarig-payment-gateway-for-wc (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/yaad-sarig-payment-gateway-for-wc"><img src="https://laskyr.com/plugins/yaad-sarig-payment-gateway-for-wc/badge.svg" alt="Yaad Sarig Payment Gateway For WC vulnerability status"></a>