Skip to content
Laskyr

Plugins · xspeed · data as of 2026-11-04

Is xSpeed Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.6)

As of 2026-11-04. 1 issue is on record for older versions; version 1.4.3 or newer fixes all of them that state a fix.

Latest version
1.4.6
Last updated
2026-11-02
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A complete WordPress caching plugin: page cache, object cache, CDN, database cleanup and Core Web Vitals optimization, plus a built-in MCP server. — by WPDeveloper

What to do

  1. Update to the latest version (1.4.6). Anything older than 1.4.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get xspeed --field=version shows what you run; wp plugin update xspeed updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-109985 · published 2026-10-17

Stored cross-site scripting (XSS) in xSpeed Cache (1.4.2 and older)

Affected
1.4.2 and older
Fixed in
1.4.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The xSpeed Cache: AI-Powered Performance Hub with MCP, Caching & CDN plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content' parameter in all versions up to, and including, 1.4.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-109985Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
xSpeed Cache vulnerability status badge
<a href="https://laskyr.com/plugins/xspeed"><img src="https://laskyr.com/plugins/xspeed/badge.svg" alt="xSpeed Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit