Skip to content
Laskyr

Plugins · xcloner-backup-and-restore · data as of 2026-11-04

Is Backup, Restore and Migrate your sites with XC… safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.8.8)

As of 2026-11-04. 4 issues are on record for older versions; version 4.8.7 or newer fixes all of them that state a fix.

Latest version
4.8.8
Last updated
2026-10-28
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.3+

XCloner is a backup plugin that allows you to safely back up and restore your WordPress sites. You can send site backups to SFTP, Dropbox, Amazon, Goo … — by watchful

What to do

  1. Update to the latest version (4.8.8). Anything older than 4.8.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get xcloner-backup-and-restore --field=version shows what you run; wp plugin update xcloner-backup-and-restore updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-48965 · published 2026-06-15

Information disclosure in Backup, Restore and Migrate your sites with XC… (4.8.6 and older)

Affected
4.8.6 and older
Fixed in
4.8.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in XCloner <= 4.8.6 versions.

NVD CVE-2026-48965Patchstack advisory

medium 4.3 CVE-2025-11759 · published 2025-12-05

Cross-site request forgery (CSRF) in Backup, Restore and Migrate your sites with XC… (4.8.2 and older)

Affected
4.8.2 and older
Fixed in
4.8.3 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Backup, Restore and Migrate your sites with XCloner plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.8.2. This is due to missing or incorrect nonce validation on the Xcloner_Remote_Storage:save() function. This makes it possible for unauthenticated attackers to add or modify an FTP backup configuration via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Successful exploitation allows an attacker to set an attacker-controlled FTP site for backup storage and exfiltrate potentially sensitive site data.

NVD CVE-2025-11759Wordfence advisoryCode change (fix)

medium 5.3 CVE-2024-6559 · published 2024-07-16

Information disclosure in Backup, Restore and Migrate your sites with XC… (4.7.3 and older)

Affected
4.7.3 and older
Fixed in
4.7.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Backup, Restore and Migrate WordPress Sites With the XCloner Plugin plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 4.7.3. This is due the plugin utilizing sabre without preventing direct access to the files. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

NVD CVE-2024-6559Wordfence advisoryCode change (fix)

medium 6.8 CVE-2014-2340 · published 2014-04-03

Cross-site request forgery (CSRF) in Backup, Restore and Migrate your sites with XC… (older than 3.1.1)

Affected
older than 3.1.1
Fixed in
3.1.1
Range from
advisory text · score by NVD
Details from the advisory

Cross-site request forgery (CSRF) vulnerability in the XCloner plugin before 3.1.1 for WordPress allows remote attackers to hijack the authentication of administrators for requests that create website backups via a request to wp-admin/plugins.php.

NVD CVE-2014-2340wordpress.orgsecunia.comexploit-db.comsecurityfocus.comsecurityfocus.comhtbridge.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Backup, Restore and Migrate your sites with XC… vulnerability status badge
<a href="https://laskyr.com/plugins/xcloner-backup-and-restore"><img src="https://laskyr.com/plugins/xcloner-backup-and-restore/badge.svg" alt="Backup, Restore and Migrate your sites with XC… vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit