Skip to content
Laskyr

Plugins · x-addons-elementor · data as of 2026-11-04

Is X Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.1)

As of 2026-11-04. 4 issues are on record for older versions; version 1.9 or newer fixes all of them that state a fix.

Latest version
1.9.1
Last updated
2026-08-02
Active installs
900+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

X Addons - A powerful collection of creative and lightweight Elementor widgets that help you design beautiful websites faster and easier. — by pencilwp

What to do

  1. Update to the latest version (1.9.1). Anything older than 1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get x-addons-elementor --field=version shows what you run; wp plugin update x-addons-elementor updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24605 · published 2026-01-23

Missing authorization check in X Addons for Elementor (1.0.23 and older)

Affected
1.0.23 and older
Fixed in
1.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in pencilwp X Addons for Elementor x-addons-elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects X Addons for Elementor: from n/a through <= 1.0.23.

NVD CVE-2026-24605Patchstack advisory

medium 6.5 CVE-2026-22518 · published 2026-01-08

Cross-site scripting (XSS) in X Addons for Elementor (1.0.23 and older)

Affected
1.0.23 and older
Fixed in
1.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pencilwp X Addons for Elementor x-addons-elementor allows DOM-Based XSS.This issue affects X Addons for Elementor: from n/a through <= 1.0.23.

NVD CVE-2026-22518Patchstack advisory

medium 6.4 CVE-2025-9204 · published 2025-10-03

Stored cross-site scripting (XSS) in X Addons for Elementor (1.0.16 and older)

Affected
1.0.16 and older
Fixed in
1.0.17 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The X Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Youtube Video ID field in all versions up to, and including, 1.0.16. This is due to insufficient input sanitization and output escaping on the Youtube Video ID parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page.

NVD CVE-2025-9204Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-48132 · published 2025-05-16

Stored cross-site scripting (XSS) in X Addons for Elementor (1.0.16 and older)

Affected
1.0.16 and older
Fixed in
1.0.17
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in pencilwp X Addons for Elementor x-addons-elementor allows Stored XSS.This issue affects X Addons for Elementor: from n/a through <= 1.0.16.

NVD CVE-2025-48132Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
X Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/x-addons-elementor"><img src="https://laskyr.com/plugins/x-addons-elementor/badge.svg" alt="X Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit