Skip to content
Laskyr

Plugins · wt-smart-coupons-for-woocommerce · data as of 2026-11-04

Is Smart Coupons For WooCommerce Coupons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.3)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.0 or newer fixes all of them that state a fix.

Latest version
2.3.3
Last updated
2026-10-21
Active installs
30,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Best WooCommerce coupons plugin to create advanced coupons and discount codes with auto-apply, BOGO, free shipping, giveaways, and discount rules. — by WebToffee

What to do

  1. Update to the latest version (2.3.3). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wt-smart-coupons-for-woocommerce --field=version shows what you run; wp plugin update wt-smart-coupons-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-45438 · published 2026-05-25

Missing authorization check in Smart Coupons For WooCommerce Coupons (older than 2.3.0)

Affected
older than 2.3.0
Fixed in
2.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebToffee Smart Coupons for WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Smart Coupons for WooCommerce: from n/a before 2.3.0.

NVD CVE-2026-45438Patchstack advisory

medium 4.3 CVE-2025-64358 · published 2025-10-31

Missing authorization check in Smart Coupons For WooCommerce Coupons (2.2.3 and older)

Affected
2.2.3 and older
Fixed in
2.2.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebToffee Smart Coupons for WooCommerce wt-smart-coupons-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Smart Coupons for WooCommerce: from n/a through <= 2.2.3.

NVD CVE-2025-64358Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Smart Coupons For WooCommerce Coupons vulnerability status badge
<a href="https://laskyr.com/plugins/wt-smart-coupons-for-woocommerce"><img src="https://laskyr.com/plugins/wt-smart-coupons-for-woocommerce/badge.svg" alt="Smart Coupons For WooCommerce Coupons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit