Skip to content
Laskyr

Plugins · wsp-mcp-ai-agents-connector · data as of 2026-11-04

Is WSP MCP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.9.7)

As of 2026-11-04. 2 issues are on record for older versions; version 2.9.6 or newer fixes all of them that state a fix.

Latest version
2.9.7
Last updated
2026-10-29
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free MCP plugin for WordPress. Connect Claude, ChatGPT, Cursor or any AI agent and manage your site by chat. 200+ tools, no coding needed. — by Bilal Naseer

What to do

  1. Update to the latest version (2.9.7). Anything older than 2.9.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wsp-mcp-ai-agents-connector --field=version shows what you run; wp plugin update wsp-mcp-ai-agents-connector updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-109382 · published 2026-10-16

Information disclosure in WSP MCP (2.9.5 and older)

Affected
2.9.5 and older
Fixed in
2.9.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WSP MCP AI Agents Connector plugin for WordPress is vulnerable to Sensitive Information Disclosure in versions up to, and including, 2.9.5. This is due to the wsp_get_posts MCP tool being registered with an empty capability requirement while the MCP endpoint's authenticate() method accepts any logged-in user, and the wsp_execute_get_posts() callback honouring a caller-supplied status=all argument that expands into a WP_Query over 'publish', 'draft', 'pending' and 'future' posts with no author or ownership filter. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the titles, URLs, authors, categories, tags and 40-word excerpts of every unpublished (draft/pending/scheduled) post on the site.

NVD CVE-2026-109382Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2026-93529 · published 2026-09-23

Missing authorization check in WSP MCP (2.7.0 and older)

Affected
2.7.0 and older
Fixed in
2.7.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Broken Access Control in WSP MCP &#8211; AI Agents Connector <= 2.7.0 versions.

NVD CVE-2026-93529Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WSP MCP vulnerability status badge
<a href="https://laskyr.com/plugins/wsp-mcp-ai-agents-connector"><img src="https://laskyr.com/plugins/wsp-mcp-ai-agents-connector/badge.svg" alt="WSP MCP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit