Skip to content
Laskyr

Plugins · wpzoom-portfolio · data as of 2026-11-04

Is WPZOOM Portfolio Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.36)

As of 2026-11-04. 4 issues are on record for older versions; version 1.4.34 or newer fixes all of them that state a fix.

Latest version
1.4.36
Last updated
2026-11-03
Active installs
20,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Portfolio plugin for WordPress. Create filterable portfolio grids with masonry layouts and lightbox. Ideal for photographers, designers, agencies. — by WPZOOM

What to do

  1. Update to the latest version (1.4.36). Anything older than 1.4.34 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpzoom-portfolio --field=version shows what you run; wp plugin update wpzoom-portfolio updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-110514 · published 2026-10-21

Missing authorization check in WPZOOM Portfolio Lite (older than 1.4.34)

Affected
older than 1.4.34
Fixed in
1.4.34
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The WPZOOM Portfolio Lite WordPress plugin before 1.4.34 does not check that a user is allowed to edit a post before changing its type and order, which could allow users with the contributor role and above to convert any other user's posts and pages into portfolio items, removing them from their original listings and URLs.

NVD CVE-2026-110514WPScan advisory

high 7.1 CVE-2026-57712 · published 2026-07-13

Reflected cross-site scripting (XSS) in WPZOOM Portfolio Lite (1.4.29 and older)

Affected
1.4.29 and older
Fixed in
1.4.30
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Portfolio wpzoom-portfolio allows Reflected XSS.This issue affects WPZOOM Portfolio: from n/a through <= 1.4.29.

NVD CVE-2026-57712Patchstack advisory

high 7.1 CVE-2026-49069 · published 2026-06-10

Reflected cross-site scripting (XSS) in WPZOOM Portfolio Lite (1.4.21 and older)

Affected
1.4.21 and older
Fixed in
1.4.22
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM Portfolio allows Reflected XSS. This issue affects WPZOOM Portfolio: from n/a through 1.4.21.

NVD CVE-2026-49069Patchstack advisory

medium 5.4 CVE-2024-8276 · published 2024-08-31

Stored cross-site scripting (XSS) in WPZOOM Portfolio Lite (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPZOOM Portfolio Lite – Filterable Portfolio Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:wpzoom-blocks' Gutenberg block in all versions up to, and including, 1.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8276Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPZOOM Portfolio Lite vulnerability status badge
<a href="https://laskyr.com/plugins/wpzoom-portfolio"><img src="https://laskyr.com/plugins/wpzoom-portfolio/badge.svg" alt="WPZOOM Portfolio Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit